summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2019-05-25 17:01:09 +0200
committerMartino Pilia2019-05-25 17:01:09 +0200
commit604993ed51c8f22075cdfa44bc3101f3d5a939d7 (patch)
treece901642ccbb0becbd1de536cde86bfba5bb50b3
parentc618dcceb538d85c43ace43e5b0bd3b1003bdd6c (diff)
downloadaur-604993ed51c8f22075cdfa44bc3101f3d5a939d7.tar.gz
Version 5.0.0
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD37
2 files changed, 22 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cfb90efa22e..75dae3ce5911 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,18 @@
pkgbase = python-itk
pkgdesc = Open-source toolkit for multidimensional image analysis
- pkgver = 4.13.2.post1
+ pkgver = 5.0.0
pkgrel = 1
url = https://itk.org/
arch = x86_64
license = Apache
- makedepends = python-pip
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = git
+ makedepends = python-scikit-build
+ makedepends = python-setuptools
depends = python-numpy
- noextract = itk-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- noextract = itk_segmentation-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- noextract = itk_io-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- noextract = itk_registration-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- noextract = itk_core-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- noextract = itk_numerics-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- noextract = itk_filtering-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- options = !strip
- source = https://files.pythonhosted.org/packages/cp37/i/itk/itk-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- source = https://files.pythonhosted.org/packages/cp37/i/itk-segmentation/itk_segmentation-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- source = https://files.pythonhosted.org/packages/cp37/i/itk-io/itk_io-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- source = https://files.pythonhosted.org/packages/cp37/i/itk-registration/itk_registration-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- source = https://files.pythonhosted.org/packages/cp37/i/itk-core/itk_core-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- source = https://files.pythonhosted.org/packages/cp37/i/itk-numerics/itk_numerics-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- source = https://files.pythonhosted.org/packages/cp37/i/itk-filtering/itk_filtering-4.13.2.post1-cp37-cp37m-manylinux1_x86_64.whl
- md5sums = 89e1e0c3c65ceefa17650078f717c39c
- md5sums = 9eaf17219f1a01b7ed2cbebf0f85cf0f
- md5sums = faf843f285db893b8abf22e940de942d
- md5sums = 4d95fd6f61a1f4c16453da1d96c1366a
- md5sums = dda686c97d792e3ac85a3e4717f96565
- md5sums = 570facb31b3a666042f53f18ce45a990
- md5sums = 25fafa150f3d547364cf52c16866cf6b
+ source = https://files.pythonhosted.org/packages/source/i/itk/itk-5.0.0.zip
+ sha256sums = 524af5ee66709b59c86cbf0d81df1524ca3b77ffc7d328ceecb97f81938fd9d1
pkgname = python-itk
diff --git a/PKGBUILD b/PKGBUILD
index 6064651af651..403e135fff5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,34 @@
# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
-_components='itk itk-segmentation itk-io itk-registration itk-core itk-numerics itk-filtering'
-_py=cp37
+_name=itk
pkgname=python-itk
-pkgver=4.13.2.post1
+pkgver=5.0.0
pkgrel=1
pkgdesc="Open-source toolkit for multidimensional image analysis"
arch=('x86_64')
url='https://itk.org/'
license=('Apache')
depends=('python-numpy')
-makedepends=('python-pip')
-options=('!strip')
-optdepends=()
-source=()
-md5sums=('89e1e0c3c65ceefa17650078f717c39c'
- '9eaf17219f1a01b7ed2cbebf0f85cf0f'
- 'faf843f285db893b8abf22e940de942d'
- '4d95fd6f61a1f4c16453da1d96c1366a'
- 'dda686c97d792e3ac85a3e4717f96565'
- '570facb31b3a666042f53f18ce45a990'
- '25fafa150f3d547364cf52c16866cf6b')
-
-for _name in $_components; do
- source+=("https://files.pythonhosted.org/packages/$_py/${_name::1}/$_name/${_name/-/_}-$pkgver-$_py-${_py}m-manylinux1_x86_64.whl")
-done
-
-noextract=("${source[@]##*/}")
+makedepends=(
+ 'cmake'
+ 'doxygen'
+ 'git'
+ 'python-scikit-build'
+ 'python-setuptools'
+)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.zip")
+sha256sums=('524af5ee66709b59c86cbf0d81df1524ca3b77ffc7d328ceecb97f81938fd9d1')
package() {
# NOTE
- # Not all image types are wrapped in the official Python wheel.
+ # Not all image types are wrapped by default.
# If you need any type that is not included, you should build
# ITK from sources using the insight-toolkit package, editing
# the PKGBUILD to enable Python wrapping and adding to the CMake
# confing any additional component you want to include.
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
- python -O -m compileall "${pkgdir}/usr/lib/python3.7/site-packages/itk"
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --optimize=1 --root="$pkgdir"
}