summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-07-12 20:31:32 +0200
committerFabioLolix2021-07-12 20:31:32 +0200
commit6052fd5eb9d92e666e7da5a5f0ccae779cf4a376 (patch)
tree7e9c3cd9ddcfac19087ee42104e1b169f16dbc78
parent002771164e546fe734be9935fcc433aa73aa9ffd (diff)
downloadaur-6052fd5eb9d92e666e7da5a5f0ccae779cf4a376.tar.gz
v1.7.0-stable2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6d9b745a44c..350c5bbe3e82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = sayonara-player
pkgdesc = Small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend.
- pkgver = 1.7.0_stable1
+ pkgver = 1.7.0_stable2
pkgrel = 1
- url = http://sayonara-player.com
+ url = https://sayonara-player.com/
arch = i686
arch = x86_64
license = GPL3
@@ -17,8 +17,10 @@ pkgbase = sayonara-player
optdepends = gst-libav: additional codecs
optdepends = gst-plugins-bad: additional codecs
optdepends = gst-plugins-ugly: additional codecs
- source = https://sayonara-player.com/files/sayonara-player-1.7.0-stable1.tar.gz
- sha512sums = b9e09770fb6a4dd2ee9ef2691f844e07cd4ed82467c1a70858538a2af1173308ec45481fc7bc48ba7d0183079befb603a44f352ee7e71073bb16f2e62dcb2177
+ source = https://sayonara-player.com/files/source/1.7.0-stable2/sayonara-player-1.7.0-stable2.tar.gz
+ source = sayonara-stationAt.patch::https://gitlab.com/luciocarreras/sayonara-player/-/commit/9b29ccb521260b744f1a1dd4e9f060b6f8ac0f00.patch
+ sha512sums = ed228a318e7ec3b92e60a3b40bb1fa467ac0c1f4b705142f8f7f63c2c0ef67a5445a52ad3782962d08f7303940b4177f90ea48d908fc40c6a46f8504f3723061
+ sha512sums = 86a29cbb01551d3c68b455085610311171f8332dc8911bceeeef30bc26501a2abae7b260747fea4862ca09606d30353a4e1a44f3991cf993f34acc4971253b33
pkgname = sayonara-player
diff --git a/PKGBUILD b/PKGBUILD
index a47c7dcfb87b..a9857c21ed2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,27 @@
# Contributor: Fixed Torres <aur_linuxero@outlook.com>
pkgname=sayonara-player
-_pkgver=1.7.0-stable1
+_pkgver=1.7.0-stable2
pkgver=${_pkgver//-/_}
pkgrel=1
pkgdesc="Small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend."
arch=(i686 x86_64)
-url="http://sayonara-player.com"
+url="https://sayonara-player.com/"
license=(GPL3)
depends=(qt5-base taglib gst-plugins-base gst-plugins-good)
makedepends=(cmake qt5-tools qt5-svg gst-plugins-bad)
optdepends=('gst-libav: additional codecs'
'gst-plugins-bad: additional codecs'
'gst-plugins-ugly: additional codecs')
-source=("https://sayonara-player.com/files/sayonara-player-${_pkgver}.tar.gz")
-sha512sums=('b9e09770fb6a4dd2ee9ef2691f844e07cd4ed82467c1a70858538a2af1173308ec45481fc7bc48ba7d0183079befb603a44f352ee7e71073bb16f2e62dcb2177')
+source=("https://sayonara-player.com/files/source/${_pkgver}/sayonara-player-${_pkgver}.tar.gz"
+ "sayonara-stationAt.patch::https://gitlab.com/luciocarreras/sayonara-player/-/commit/9b29ccb521260b744f1a1dd4e9f060b6f8ac0f00.patch")
+sha512sums=('ed228a318e7ec3b92e60a3b40bb1fa467ac0c1f4b705142f8f7f63c2c0ef67a5445a52ad3782962d08f7303940b4177f90ea48d908fc40c6a46f8504f3723061'
+ '86a29cbb01551d3c68b455085610311171f8332dc8911bceeeef30bc26501a2abae7b260747fea4862ca09606d30353a4e1a44f3991cf993f34acc4971253b33')
prepare() {
cd "${srcdir}/${pkgname}-${_pkgver}"
[[ -d build ]] || mkdir build
+ patch -Np1 -i ../sayonara-stationAt.patch
}
build() {