summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2017-01-12 01:47:39 +0200
committerAdrian Perez de Castro2017-01-12 01:47:39 +0200
commit605d50f2766b60247a79d4eb80c2b59e629f2999 (patch)
tree87fe1dc66dbb5249cd11ac6539f56a9f42a92867
downloadaur-605d50f2766b60247a79d4eb80c2b59e629f2999.tar.gz
Initial import
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bf92feb7aa3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ttf-cutive-mono
+ pkgver = 1.001
+ pkgrel = 1
+ arch = any
+ license = custom:OFL
+ source = https://github.com/vernnobile/CutiveFont/raw/master/CutiveMono/GWF-1.001/CutiveMono-Regular.ttf
+ source = https://github.com/vernnobile/CutiveFont/raw/master/CutiveMono/GWF-1.001/OFL.txt
+ sha512sums = baf0acc7ebf13087244c286445d85db0ddb57ef24685c6696e2e9cbd637493c4f50e4b2ffe44ce85190daea5533ae00a714fce716d664209b46168946bd1f491
+ sha512sums = ba9ad59388c5a862aef48d976ee7a72839b10ad9da5b74d0ca98adad7b81cabd6207e407ce914f9845fd60e272ce878f7d4b5d5d635378de5806e412fe2f2515
+
+pkgname = ttf-cutive-mono
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8980007aad8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
+pkgname='ttf-cutive-mono'
+pkgver='1.001'
+pkgrel='1'
+description='Monospaced font based on the IBM Executive typewriters.'
+arch=('any')
+license=('custom:OFL')
+_dl_base_url='https://github.com/vernnobile/CutiveFont/raw/master/CutiveMono/GWF-1.001'
+source=("${_dl_base_url}/CutiveMono-Regular.ttf"
+ "${_dl_base_url}/OFL.txt")
+sha512sums=('baf0acc7ebf13087244c286445d85db0ddb57ef24685c6696e2e9cbd637493c4f50e4b2ffe44ce85190daea5533ae00a714fce716d664209b46168946bd1f491'
+ 'ba9ad59388c5a862aef48d976ee7a72839b10ad9da5b74d0ca98adad7b81cabd6207e407ce914f9845fd60e272ce878f7d4b5d5d635378de5806e412fe2f2515')
+
+package () {
+ install -m755 -d "${pkgdir}/usr/share/fonts/ttf-comme"
+ install -m644 -t "${pkgdir}/usr/share/fonts/ttf-comme" "${srcdir}"/*.ttf
+ install -Dm644 "${srcdir}/OFL.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/OFL"
+}