summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Slipchenko2019-01-24 22:39:29 +0300
committerSergey Slipchenko2019-01-24 22:40:08 +0300
commit605ebb9df305122bb57407edd177a3fa07bdea49 (patch)
treea3e016a601ed9809e7ebc6e13d19cacfebf2295d
parent91030bc72024fe5a6d9b8f57e433a959ac29d7ef (diff)
downloadaur-605ebb9df305122bb57407edd177a3fa07bdea49.tar.gz
Do not patch systemd unit
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--01-change-systemd-unit.patch19
-rw-r--r--PKGBUILD21
4 files changed, 11 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe7da1769c15..1769d79e35b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,12 +8,10 @@ pkgbase = plymouth-lite-rbp-git
makedepends = git
provides = plymouth-lite-rbp
conflicts = plymouth-lite-rbp
- source = plymouth-lite-rbp::git+https://github.com/T4d3o/Plymouth-lite.git
- source = 01-change-systemd-unit.patch
+ source = git+https://github.com/T4d3o/Plymouth-lite.git
source = initcpio_hook
source = initcpio_install
md5sums = SKIP
- md5sums = 709d24411c2fcd62b2eccbfc98010b25
md5sums = 86dcab222ab4be45fc96d2792ff91809
md5sums = e13f4e22ee8e28eef85028c9307bfc3f
diff --git a/.gitignore b/.gitignore
index 3b72de0ed298..29185534b339 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
*.pkg.tar.xz
pkg
-plymouth-lite-rbp
+Plymouth-lite
src
diff --git a/01-change-systemd-unit.patch b/01-change-systemd-unit.patch
deleted file mode 100644
index 49b9820f24a4..000000000000
--- a/01-change-systemd-unit.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/systemd/plymouth-lite-start.service b/systemd/plymouth-lite-start.service
-index bed69ac..fb377f3 100644
---- a/systemd/plymouth-lite-start.service
-+++ b/systemd/plymouth-lite-start.service
-@@ -2,9 +2,12 @@
- Description=Show Plymouth-lite Start Screen
- DefaultDependencies=no
- After=systemd-vconsole-setup.service
--Before=sysinit.target
-+Before=kodi.service
-
- [Service]
- Type=oneshot
- RemainAfterExit=yes
--ExecStart=/usr/bin/ply-image /usr/share/plymouth/splash.png
-+ExecStart=/usr/bin/echo 0 > /sys/class/graphics/fbcon/cursor_blink ; /usr/bin/echo 0 > /sys/devices/virtual/graphics/fbcon/cursor_blink ; /usr/bin/chvt 7 ; /usr/bin/ply-image
-+
-+[Install]
-+WantedBy=multi-user.target
diff --git a/PKGBUILD b/PKGBUILD
index 21118262d5e4..01b9d7727daa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sergey Slipchenko <faergeek@gmail.com>
pkgname=plymouth-lite-rbp-git
pkgver=r10.76e20e8
-pkgrel=1
+pkgrel=2
pkgdesc="Plymouth-lite patched and ready for Raspberry Pi"
arch=('armv7h')
url="https://github.com/T4d3o/Plymouth-lite"
@@ -9,31 +9,28 @@ license=('GPL2')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('plymouth-lite-rbp::git+https://github.com/T4d3o/Plymouth-lite.git'
- '01-change-systemd-unit.patch' 'initcpio_hook' 'initcpio_install')
+source=('git+https://github.com/T4d3o/Plymouth-lite.git'
+ 'initcpio_hook'
+ 'initcpio_install')
md5sums=('SKIP'
- '709d24411c2fcd62b2eccbfc98010b25'
'86dcab222ab4be45fc96d2792ff91809'
'e13f4e22ee8e28eef85028c9307bfc3f')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd Plymouth-lite
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- patch -Np1 -i "$srcdir/01-change-systemd-unit.patch"
-}
-
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd Plymouth-lite
+
make
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd Plymouth-lite
+
make DESTDIR="$pkgdir/" install
mkdir -p $pkgdir/usr/lib/systemd/system/
install -Dm0644 systemd/* $pkgdir/usr/lib/systemd/system/