summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOnur Alp Akin2022-11-26 12:02:42 +0300
committerOnur Alp Akin2022-11-26 12:02:42 +0300
commit60711d13ec8cf1e1a995ccd4b8cb6c14f2eb0202 (patch)
treeda1ce33f5e22e21652ed417f40e772e71cbbe046
downloadaur-60711d13ec8cf1e1a995ccd4b8cb6c14f2eb0202.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8662244256db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = l5p-kbl-git
+ pkgdesc = Lenovo Legion 5 Pro 2021 Linux Keyboard Light Controller
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/imShara/l5p-kbl
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = python
+ depends = python-pyusb
+ source = git+https://github.com/imShara/l5p-kbl
+ md5sums = SKIP
+
+pkgname = l5p-kbl-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4ed90e7afe2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Onur Alp Akin <onralpakin@gmail.com>
+pkgname=l5p-kbl-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="Lenovo Legion 5 Pro 2021 Linux Keyboard Light Controller"
+arch=('any')
+url="https://github.com/imShara/l5p-kbl"
+license=('unknown')
+depends=('python' 'python-pyusb')
+makedepends=('git')
+source=("git+${url}")
+md5sums=('SKIP')
+
+package() {
+ cd ${pkgname%-git}
+
+ install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm 755 l5p_kbl.py "${pkgdir}/usr/bin/l5p-kbl"
+}