summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Goy2018-07-20 23:16:07 +0200
committerNicolas Goy2018-07-20 23:16:07 +0200
commit608e74c76951452efa5bded30cfd642e9985e1c3 (patch)
treed04de094b3a7eab85816d3d8dc6c928395a8681c
downloadaur-608e74c76951452efa5bded30cfd642e9985e1c3.tar.gz
zrep v1.7.3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..212b0a73d1f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = zrep
+ pkgdesc = ZREP ZFS based replication and failover script from bolthole.com
+ pkgver = 1.7.3
+ pkgrel = 1
+ url = https://github.com/bolthole/zrep
+ arch = any
+ license = custom
+ depends = ksh
+ source = https://raw.githubusercontent.com/bolthole/zrep/v1.7.3/zrep
+ source = https://raw.githubusercontent.com/bolthole/zrep/master/LICENSE.txt
+ md5sums = c1d9b42965af9f502f973dafbc8073d2
+ md5sums = c8bab7291304d748f1133dbd43c992df
+
+pkgname = zrep
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6aa1a768ea86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Nicolas Goy <kuon@goyman.com>
+
+pkgname=zrep
+pkgver=1.7.3
+pkgrel=1
+epoch=
+pkgdesc="ZREP ZFS based replication and failover script from bolthole.com"
+arch=("any")
+url="https://github.com/bolthole/zrep"
+license=('custom')
+groups=()
+depends=(ksh)
+source=("https://raw.githubusercontent.com/bolthole/zrep/v$pkgver/$pkgname"
+"https://raw.githubusercontent.com/bolthole/zrep/master/LICENSE.txt")
+md5sums=('c1d9b42965af9f502f973dafbc8073d2' 'c8bab7291304d748f1133dbd43c992df')
+
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname/
+ cp $srcdir/LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/
+ chmod +x $srcdir/$pkgname
+ cp $srcdir/$pkgname $pkgdir/usr/bin
+}