summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2019-03-15 00:25:32 -0300
committerandalenavals2019-03-15 00:25:32 -0300
commit60961a91029c2410797e3e01d921496d7bd115ad (patch)
treead37ba45cee732601052279cc06dd279fb4a9c71
parente1c3cca8122e330216e77ac227301fb1bdcdd847 (diff)
downloadaur-60961a91029c2410797e3e01d921496d7bd115ad.tar.gz
including check missing test depending of piff itself
-rwxr-xr-x.SRCINFO10
-rwxr-xr-xPKGBUILD44
2 files changed, 32 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cf158fcc84c..bd84ce5d1dac 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,13 +8,15 @@ pkgbase = python-piff-git
checkdepends = python-nose
checkdepends = python2-nose
checkdepends = python-scikit-learn
+ checkdepends = python-uncertainties
+ checkdepends = python2-uncertainties
makedepends = git
makedepends = python
makedepends = libffi
makedepends = python-cffi
makedepends = python-numpy
makedepends = python-scipy
- makedepends = python-pyaml
+ makedepends = python-yaml
makedepends = python-treecorr-git
makedepends = python-fitsio-git
makedepends = python-lmfit-git
@@ -23,7 +25,7 @@ pkgbase = python-piff-git
makedepends = python2-cffi
makedepends = python2-numpy
makedepends = python2-scipy
- makedepends = python2-pyaml
+ makedepends = python2-yaml
makedepends = python2-treecorr-git
makedepends = python2-fitsio-git
makedepends = python2-lmfit-git
@@ -35,6 +37,8 @@ pkgbase = python-piff-git
optdepends = python2-scikit-learn
optdepends = python-piff
optdepends = python2-piff
+ optdepends = python2-pyaml
+ optdepends = python2-yaml
conflicts = python-piff
conflicts = python2-piff
source = python-piff-git::git+https://github.com/rmjarvis/Piff.git#tag=v0.2.5
@@ -42,6 +46,7 @@ pkgbase = python-piff-git
pkgname = python-piff-git
depends = python-cffi
+ depends = python-yaml
depends = python-numpy
depends = python-scipy
depends = python-pyaml
@@ -54,6 +59,7 @@ pkgname = python-piff-git
pkgname = python2-piff-git
depends = python2-cffi
+ depends = python2-yaml
depends = python2-numpy
depends = python2-scipy
depends = python2-pyaml
diff --git a/PKGBUILD b/PKGBUILD
index 61875be300f8..bf87489aea22 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,9 @@
# then please put 'unknown'.
# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
-# Contributor: M. Jarvis
+# Contributor: M. Jarvis
+_tag=v0.2.5
+_pkgname=python-piff-git
pkgbase=python-piff-git
pkgname=('python-piff-git' 'python2-piff-git')
pkgver=v0.2.5.r0.gdee19b7
@@ -15,48 +17,50 @@ field of view"
arch=('any')
url="https://github.com/rmjarvis/Piff.git"
license=('BSD')
-makedepends=('git' 'python' 'libffi' 'python-cffi' 'python-numpy' 'python-scipy' 'python-pyaml' 'python-treecorr-git' 'python-fitsio-git' 'python-lmfit-git' 'python-matplotlib' 'python2' 'python2-cffi' 'python2-numpy' 'python2-scipy' 'python2-pyaml' 'python2-treecorr-git' 'python2-fitsio-git' 'python2-lmfit-git' 'python2-matplotlib' 'python-galsim-git' 'python2-galsim-git' 'python-coord-git' 'python2-coord-git')
-optdepends=('python2-scikit-learn' 'python-piff' 'python2-piff')
-checkdepends=('python-nose' 'python2-nose' 'python-scikit-learn' )
+makedepends=('git' 'python' 'libffi' 'python-cffi' 'python-numpy' 'python-scipy' 'python-yaml' 'python-treecorr-git' 'python-fitsio-git' 'python-lmfit-git' 'python-matplotlib' 'python2' 'python2-cffi' 'python2-numpy' 'python2-scipy' 'python2-yaml' 'python2-treecorr-git' 'python2-fitsio-git' 'python2-lmfit-git' 'python2-matplotlib' 'python-galsim-git' 'python2-galsim-git' 'python-coord-git' 'python2-coord-git')
+optdepends=('python2-scikit-learn' 'python-piff' 'python2-piff' 'python2-pyaml' 'python2-yaml')
+checkdepends=('python-nose' 'python2-nose' 'python-scikit-learn' 'python-uncertainties' 'python2-uncertainties' )
conflicts=('python-piff' 'python2-piff')
-source=("${pkgbase}::git+${url}#tag=v0.2.5")
+source=("${pkgbase}::git+${url}#tag=$_tag")
md5sums=('SKIP')
pkgver() {
- cd "${pkgbase}"
+ cd "$srcdir"/$_pkgname
printf "%s" "$(git describe --long | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g')"
}
prepare() {
- cp -a $pkgbase{,-py2}
+ cp -a $_pkgname{,-py2}
}
build() {
- cd "$srcdir"/$pkgbase
+ cd "$srcdir"/$_pkgname
python setup.py build
- cd "$srcdir"/$pkgbase-py2
+ cd "$srcdir"/$_pkgname-py2
python2 setup.py build
}
-#check() {
-# cd "$srcdir"/$pkgbase
-# nosetests -v || warning 'Tests failed'
-#
-# cd "$srcdir"/$pkgbase-py2
-# nosetests2 -v || warning 'Tests2 failed'
-#}
+check() {
+ cd "$srcdir"/$_pkgname/tests
+ git checkout "$_tag"
+ nosetests -v || warning 'Tests failed'
+
+ cd "$srcdir"/$_pkgname-py2/tests
+ git checkout "$_tag"
+ nosetests2 -v || warning 'Tests2 failed'
+}
package_python-piff-git() {
- depends=('python-cffi' 'python-numpy' 'python-scipy' 'python-pyaml' 'python-treecorr-git' 'python-fitsio-git' 'python-lmfit-git' 'python-matplotlib' 'python-galsim-git' 'python-coord-git')
- cd $pkgbase
+ depends=('python-cffi' 'python-yaml' 'python-numpy' 'python-scipy' 'python-pyaml' 'python-treecorr-git' 'python-fitsio-git' 'python-lmfit-git' 'python-matplotlib' 'python-galsim-git' 'python-coord-git')
+ cd "${_pkgname}"
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
}
package_python2-piff-git() {
- depends=('python2-cffi' 'python2-numpy' 'python2-scipy' 'python2-pyaml' 'python2-treecorr-git' 'python2-fitsio-git' 'python2-matplotlib' 'python2-galsim-git' 'python2-coord-git')
- cd $pkgbase-py2
+ depends=('python2-cffi' 'python2-yaml' 'python2-numpy' 'python2-scipy' 'python2-pyaml' 'python2-treecorr-git' 'python2-fitsio-git' 'python2-matplotlib' 'python2-galsim-git' 'python2-coord-git')
+ cd "${_pkgname}"
python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
mv "$pkgdir"/usr/bin/piffify{,2}
#mv "$pkgdir"/usr/bin/plotify{,2}