summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2020-07-09 21:07:02 +0000
committerBalló György2020-07-09 21:07:02 +0000
commit60a08ffc5b2b6e7f2c1d4ac403e1fec4b977efa9 (patch)
treec55eb0fdec3cf14c6140d1d9abc2d8f6af2c27a0
parente4fa8ae59c87b4d9af80037928d744a9f3f8d5ed (diff)
downloadaur-60a08ffc5b2b6e7f2c1d4ac403e1fec4b977efa9.tar.gz
Build with Qt5
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD57
-rw-r--r--equalx.install3
-rw-r--r--qt-5.11.patch16
4 files changed, 58 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53edc9fea7c2..f95d02299508 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
-# Generated by mksrcinfo v8
-# Wed Sep 13 20:26:58 UTC 2017
pkgbase = equalx
pkgdesc = Makes you easily write equations in LaTeX and preview them in real-time
pkgver = 0.7.1
- pkgrel = 3
+ pkgrel = 4
url = http://equalx.sourceforge.net/
- install = equalx.install
- arch = i686
arch = x86_64
license = GPL3
- depends = qt4
depends = exempi
- depends = texlive-bin
+ depends = ghostscript
+ depends = hicolor-icon-theme
depends = poppler
- optdepends = ghostscript: to export pdf and ps
- source = http://downloads.sourceforge.net/project/equalx/EqualX-0.7/equalx-0.7.1.tar.gz
- md5sums = f7164b254f25fb265388b46e3fb8e464
+ depends = qt5-base
+ depends = texlive-bin
+ source = https://downloads.sourceforge.net/equalx/equalx-0.7.1.tar.gz
+ source = qt-5.11.patch
+ sha256sums = 7f62e580206bc0e8e83a39bf4161bf6a6b0cd268507d5e1ad0781eeba1191f8b
+ sha256sums = 39bc412cde6f911e032adcbf1316a2d8f10500a46456739972f42d639504af6a
pkgname = equalx
diff --git a/PKGBUILD b/PKGBUILD
index d41a9899aea3..737ec3e2b234 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,49 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=equalx
pkgver=0.7.1
-pkgrel=3
-pkgdesc="Makes you easily write equations in LaTeX and preview them in real-time"
+pkgrel=4
+pkgdesc='Makes you easily write equations in LaTeX and preview them in real-time'
+arch=(x86_64)
url="http://equalx.sourceforge.net/"
-depends=("qt4" "exempi" "texlive-bin" "poppler")
-optdepends=("ghostscript: to export pdf and ps")
-license=("GPL3")
-source=("http://downloads.sourceforge.net/project/${pkgname}/EqualX-${pkgver%.*}/${pkgname}-${pkgver}.tar.gz")
-arch=('i686' 'x86_64')
-install=equalx.install
-md5sums=('f7164b254f25fb265388b46e3fb8e464')
+license=(GPL3)
+depends=(exempi ghostscript hicolor-icon-theme poppler qt5-base texlive-bin)
+source=(https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ qt-5.11.patch)
+sha256sums=('7f62e580206bc0e8e83a39bf4161bf6a6b0cd268507d5e1ad0781eeba1191f8b'
+ '39bc412cde6f911e032adcbf1316a2d8f10500a46456739972f42d639504af6a')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i ../qt-5.11.patch
+ sed -i '/Icon=/cIcon=equalx' resources/equalx.desktop
+}
- qmake-qt4
+build() {
+ cd $pkgname-$pkgver
+ qmake
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
+
+ install -Dm755 equalx "${pkgdir}/usr/bin/equalx"
- install -Dm755 "equalx" "${pkgdir}/usr/bin/equalx"
for _symbol in $(find resources/symbols -type f); do
- install -Dm644 "${_symbol}" "${pkgdir}/usr/share/equalx/${_symbol}"
+ install -Dm644 $_symbol "$pkgdir/usr/share/equalx/$_symbol"
done
- install -Dm644 "resources/equalx.desktop" \
- "${pkgdir}/usr/share/applications/equalx.desktop"
- sed -i '/Icon=/cIcon=equalx' "${pkgdir}/usr/share/applications/equalx.desktop"
+
+ install -Dm644 resources/equalx.desktop \
+ "$pkgdir/usr/share/applications/equalx.desktop"
+
for _size in 16 22 24 32 48 64 128; do
- install -Dm644 "resources/icons/equalx/equalx-${_size}x${_size}.png" \
- "${pkgdir}/usr/share/icons/hicolor/${_size}x${_size}/apps/equalx.png"
+ install -Dm644 resources/icons/equalx/equalx-${_size}x${_size}.png \
+ "$pkgdir/usr/share/icons/hicolor/${_size}x${_size}/apps/equalx.png"
done
- install -Dm644 "resources/icons/equalx/equalx.svg" \
- "${pkgdir}"/usr/share/icons/hicolor/scalable/apps/equalx.svg
- install -Dm644 "equalx.1" "${pkgdir}/usr/share/man/man1/equalx.1"
+
+ install -Dm644 resources/icons/equalx/equalx.svg \
+ "$pkgdir/usr/share/icons/hicolor/scalable/apps/equalx.svg"
+
+ install -Dm644 equalx.1 "$pkgdir/usr/share/man/man1/equalx.1"
}
diff --git a/equalx.install b/equalx.install
deleted file mode 100644
index b5ca1e58ea60..000000000000
--- a/equalx.install
+++ /dev/null
@@ -1,3 +0,0 @@
-post_upgrade() {
- echo "If EqualX segfaults / crashes when starting you might have to delete ~/.config/equalx/settings.conf"
-}
diff --git a/qt-5.11.patch b/qt-5.11.patch
new file mode 100644
index 000000000000..873bc019c862
--- /dev/null
+++ b/qt-5.11.patch
@@ -0,0 +1,16 @@
+Description: Fix FTBFS with Qt 5.11
+Author: Juhani Numminen <juhaninumminen0@gmail.com>
+Bug: https://bugs.launchpad.net/equalx/+bug/1789117
+Bug-Debian: https://bugs.debian.org/907227
+Last-Update: 2018-08-26
+
+--- a/src/DialogPreferences.cpp
++++ b/src/DialogPreferences.cpp
+@@ -17,6 +17,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <QAction>
+ #include <QButtonGroup>
+ #include <QFileDialog>
+