summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThammachart2022-08-28 12:47:39 +0700
committerThammachart2022-08-28 12:47:39 +0700
commit60c2d50e2033875b65acd551260338cb57fab3cb (patch)
tree454a1a2cb9d237736d55daf4629a8e6d78b80d61
parentfd61a3a11a928c29678b47e8be873c27d156d117 (diff)
downloadaur-60c2d50e2033875b65acd551260338cb57fab3cb.tar.gz
v2.2.1, otf files
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD18
3 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8163784b9d5..4877ad9ecad9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nerd-fonts-cascadia-code
pkgdesc = Patched Cascadia Code font with extra glyphs
- pkgver = 2.1.0
- pkgrel = 2
+ pkgver = 2.2.1
+ pkgrel = 1
url = https://github.com/ryanoasis/nerd-fonts
arch = any
groups = nerd-fonts
@@ -10,10 +10,9 @@ pkgbase = nerd-fonts-cascadia-code
provides = nerd-fonts-cascadia-code
conflicts = nerd-fonts-complete
conflicts = nerd-fonts-git
- source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.1.0/CascadiaCode.zip
- source = https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v2.1.0/LICENSE
- sha256sums = 92b50960305c580fc90bb3bd5456e26edc9b321907dfa2578066a9b38e2a94e0
- sha256sums = d2a29823384e9194a87936ccad495c764c2ef733b29bfa6f72a1d65803ce02e5
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.2.1/CascadiaCode.zip
+ source = https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v2.2.1/LICENSE
+ sha256sums = 06039f286c247cc5606bbc8267cdefcc01d1a1955b8da597a11c6b6fdc480c65
+ sha256sums = 245b522abb5aba0d8e84898bf6d5e95102620637626106bfd0061189a2370360
pkgname = nerd-fonts-cascadia-code
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a121394c22c6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+
+*.zip
+*.pkg.tar.zst
+LICENSE \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 0c100ee5a776..91deed01e06e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,20 @@
-# Maintainer: Owen D'Aprile <aur@owen.sh>
-# Adapted from PKGBUILD for nerd-fonts-fira-code (https://aur.archlinux.org/packages/nerd-fonts-fira-code/)
-
pkgname=nerd-fonts-cascadia-code
-pkgver=2.1.0
-pkgrel=2
+pkgver=2.2.1
+pkgrel=1
pkgdesc="Patched Cascadia Code font with extra glyphs"
arch=("any")
url="https://github.com/ryanoasis/nerd-fonts"
license=("MIT")
depends=("fontconfig")
provides=("nerd-fonts-cascadia-code")
-conflicts=("nerd-fonts-complete"
- "nerd-fonts-git")
+conflicts=("nerd-fonts-complete" "nerd-fonts-git")
groups=("nerd-fonts")
source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v${pkgver}/CascadiaCode.zip"
"https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v${pkgver}/LICENSE")
-sha256sums=("92b50960305c580fc90bb3bd5456e26edc9b321907dfa2578066a9b38e2a94e0"
- "d2a29823384e9194a87936ccad495c764c2ef733b29bfa6f72a1d65803ce02e5")
+sha256sums=("06039f286c247cc5606bbc8267cdefcc01d1a1955b8da597a11c6b6fdc480c65"
+ "245b522abb5aba0d8e84898bf6d5e95102620637626106bfd0061189a2370360")
package() {
- find . -iname "*.ttf" -not -iname "*Windows Compatible*" -execdir install -Dm644 {} "${pkgdir}/usr/share/fonts/TTF/{}" \;
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ find . -iname "*.otf" -not -iname "*Windows Compatible*" -execdir install -Dm644 {} "${pkgdir}/usr/share/fonts/OTF/{}" \;
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}