summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcdude2018-04-28 15:48:09 -0400
committercdude2018-04-28 15:48:09 -0400
commit60e8215d52c8b2297d76d57dcc5c2acd846fb66c (patch)
tree0feb3391800cd120f188c23cdddf4c93d3c05bcd
parentca41bf554d7a620cb2c31f1ee40f65222128f5fa (diff)
downloadaur-60e8215d52c8b2297d76d57dcc5c2acd846fb66c.tar.gz
Adopted package and added code to PKGBUILD to support patches.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
-rw-r--r--config.h1
3 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82ae82739662..eb9833fb194c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Aug 31 08:32:46 UTC 2017
pkgbase = surf-git
pkgdesc = a WebKit based browser
- pkgver = 2.0.r50.g723ff26
+ pkgver = 2.0.r53.g81f0452
pkgrel = 1
url = http://surf.suckless.org/
arch = i686
@@ -13,6 +11,7 @@ pkgbase = surf-git
depends = gcr
depends = xorg-xprop
optdepends = dmenu: url bar and search
+ optdepends = tabbed: tab browsing
optdepends = ca-certificates: SSL verification
optdepends = st: default terminal for the download handler
optdepends = curl: default download handler
@@ -22,7 +21,7 @@ pkgbase = surf-git
source = surf::git+https://git.suckless.org/surf
source = config.h
md5sums = SKIP
- md5sums = SKIP
+ md5sums = 61acead6e11b1980fa1bcba0ae5a1cb4
pkgname = surf-git
diff --git a/PKGBUILD b/PKGBUILD
index eb7611149f7a..1af4d030028b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
-# Maintainer: sekret
+# Maintainer: cdude
+# Contributor: sekret
+
_pkgname=surf
pkgname=$_pkgname-git
-pkgver=2.0.r50.g723ff26
+pkgver=2.0.r53.g81f0452
pkgrel=1
pkgdesc="a WebKit based browser"
arch=('i686' 'x86_64')
@@ -10,6 +12,7 @@ license=('custom:MIT/X')
depends=('webkit2gtk' 'gcr' 'xorg-xprop')
makedepends=('git')
optdepends=('dmenu: url bar and search'
+ 'tabbed: tab browsing'
'ca-certificates: SSL verification'
'st: default terminal for the download handler'
'curl: default download handler'
@@ -19,7 +22,7 @@ conflicts=("$_pkgname")
source=("$_pkgname::git+https://git.suckless.org/surf"
'config.h')
md5sums=('SKIP'
- 'SKIP')
+ '61acead6e11b1980fa1bcba0ae5a1cb4')
pkgver() {
cd "$_pkgname"
@@ -28,7 +31,15 @@ pkgver() {
prepare() {
cd "$_pkgname"
- #cp "$srcdir/config.h" .
+ for file in "${source[@]}"; do
+ if [[ "$file" == "config.h" ]]; then
+ # add config.h if present in source array
+ cp "$srcdir/$file" .
+ elif [[ "$file" == *.diff || "$file" == *.patch ]]; then
+ # add all patches present in source array
+ patch -Np1 < "$srcdir/$(basename ${file})"
+ fi
+ done
}
build() {
diff --git a/config.h b/config.h
index 2e735bfadc9b..6748f8aafe29 100644
--- a/config.h
+++ b/config.h
@@ -46,6 +46,7 @@ static Parameter defconfig[ParameterLast] = {
[SpellLanguages] = { { .v = ((char *[]){ "en_US", NULL }) }, },
[StrictTLS] = { { .i = 1 }, },
[Style] = { { .i = 1 }, },
+ [WebGL] = { { .i = 0 }, },
[ZoomLevel] = { { .f = 1.0 }, },
};