summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-01-25 23:14:43 +0100
committersL1pKn072019-01-25 23:14:43 +0100
commit60f294eea0bcfe629ed74fe11de4bf6fb82cf93c (patch)
treec60e31f5293bf7608dd28c8a123fd2824263e809
parentc89f97ff0beeb14597d4bc082df6ae4fac9728db (diff)
downloadaur-60f294eea0bcfe629ed74fe11de4bf6fb82cf93c.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83a9c6604640..bb3970c75bbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Aug 4 04:39:29 UTC 2017
+# Fri Jan 25 22:14:39 UTC 2019
pkgbase = vapoursynth-plugin-tcanny-git
pkgdesc = Plugin for Vapoursynth: tcanny (GIT version)
- pkgver = r10.0.gd309511
+ pkgver = r11.0.g88c9623
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171136
arch = i686
@@ -11,6 +11,7 @@ pkgbase = vapoursynth-plugin-tcanny-git
makedepends = git
makedepends = boost
makedepends = opencl-headers
+ makedepends = meson
depends = vapoursynth
depends = ocl-icd
provides = vapoursynth-plugin-tcanny
diff --git a/PKGBUILD b/PKGBUILD
index daacd78993b9..316277df199d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=tcanny
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r10.0.gd309511
+pkgver=r11.0.g88c9623
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -14,6 +14,7 @@ depends=('vapoursynth'
makedepends=('git'
'boost'
'opencl-headers'
+ 'meson'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
@@ -26,21 +27,19 @@ pkgver() {
}
prepare() {
- cd "${_plug}"
- ./autogen.sh
+ mkdir -p build
}
build() {
- cd "${_plug}"
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib/vapoursynth
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
- make
+ ninja
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}