summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-11-22 12:36:12 -0600
committerLuis Martinez2021-11-22 12:36:12 -0600
commit616fc2e2c58862ffdd242038b4e8a5a40f9751b8 (patch)
treef86a253905af8e5c16ee8cecf6285ab944dade57
parent7e62cd4579645b1b0f232a62ecd6a343671bf6f6 (diff)
downloadaur-616fc2e2c58862ffdd242038b4e8a5a40f9751b8.tar.gz
update to 4.0.5
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 301036603e47..38e971d68143 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pydna
pkgdesc = Data structures for double-stranded DNA & simulation of homologous recombination
- pkgver = 4.0.2
+ pkgver = 4.0.5
pkgrel = 1
url = https://github.com/bjornfjohansson/pydna
changelog = CHANGELOG.md
@@ -10,18 +10,18 @@ pkgbase = python-pydna
makedepends = python-setuptools
makedepends = python-setuptools-scm
makedepends = python-pytest-runner
- depends = python-appdirs>=1.4.3
- depends = python-biopython>=1.79
- depends = python-networkx>=2.5.0
- depends = python-prettytable>=0.7.2
- depends = python-pyparsing>=2.4.7
- depends = python-requests>=2.23.0
+ depends = python-appdirs
+ depends = python-biopython
+ depends = python-networkx
+ depends = python-prettytable
+ depends = python-pyparsing
+ depends = python-requests
optdepends = python-matplotlib: gel simulation
optdepends = python-mpldatacursor: gel simulation
optdepends = python-numpy: gel simulation
optdepends = python-pint: gel simulation
optdepends = python-scipy: gel simulation
- source = python-pydna::git+https://github.com/bjornfjohansson/pydna#tag=4.0.2
+ source = python-pydna::git+https://github.com/bjornfjohansson/pydna#tag=4.0.5
sha256sums = SKIP
pkgname = python-pydna
diff --git a/PKGBUILD b/PKGBUILD
index 631bff6b1264..c7c867246df7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,30 @@
# Contributor: Clint Valentine <valentine.clint@gmail.com>
pkgname=python-pydna
-pkgver=4.0.2
+pkgver=4.0.5
pkgrel=1
pkgdesc='Data structures for double-stranded DNA & simulation of homologous recombination'
arch=('any')
url='https://github.com/bjornfjohansson/pydna'
license=('BSD')
depends=(
- 'python-appdirs>=1.4.3'
- 'python-biopython>=1.79'
- 'python-networkx>=2.5.0'
- 'python-prettytable>=0.7.2'
- 'python-pyparsing>=2.4.7'
- 'python-requests>=2.23.0')
+ 'python-appdirs'
+ 'python-biopython'
+ 'python-networkx'
+ 'python-prettytable'
+ 'python-pyparsing'
+ 'python-requests')
optdepends=(
'python-matplotlib: gel simulation'
'python-mpldatacursor: gel simulation'
'python-numpy: gel simulation'
'python-pint: gel simulation'
'python-scipy: gel simulation')
-makedepends=('git' 'python-setuptools' 'python-setuptools-scm' 'python-pytest-runner')
+makedepends=(
+ 'git'
+ 'python-setuptools'
+ 'python-setuptools-scm'
+ 'python-pytest-runner')
changelog=CHANGELOG.md
source=("$pkgname::git+$url#tag=$pkgver")
sha256sums=('SKIP')