summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVlad Pirlog2023-07-05 00:26:18 +0300
committerVlad Pirlog2023-07-05 00:26:45 +0300
commit6174c8d6edbd201d667b8e9ab10c82cf2c1c5cfe (patch)
treef0793d5d4d681e4069a9470c1fdfe1cc512d7907
parent97b7934ef5d8eaf20f0f5d47d338d6def13f77d0 (diff)
downloadaur-6174c8d6edbd201d667b8e9ab10c82cf2c1c5cfe.tar.gz
Update to 23.2.0.178.1027
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md47
-rw-r--r--PKGBUILD4
3 files changed, 52 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d0e755be410..6535daae988d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sqlcl
pkgdesc = SQL Developer command line interface for Oracle
- pkgver = 23.1.0.089.0929
+ pkgver = 23.2.0.178.1027
pkgrel = 1
url = https://www.oracle.com/database/sqldeveloper/technologies/sqlcl
changelog = CHANGELOG.md
@@ -8,9 +8,9 @@ pkgbase = sqlcl
license = custom
depends = bash
depends = java-runtime>=8
- source = sqlcl-23.1.0.089.0929.zip::https://download.oracle.com/otn_software/java/sqldeveloper/sqlcl-23.1.0.089.0929.zip
+ source = sqlcl-23.2.0.178.1027.zip::https://download.oracle.com/otn_software/java/sqldeveloper/sqlcl-23.2.0.178.1027.zip
source = sqlcl.sh
- sha256sums = 093f0d752bd9a497e168b7f3de4a3b68ea977bfe5948e2602ad91dd3a0147568
+ sha256sums = c06a8b955f3cc9826b55b94acde1ba55eadfb048028b5250778f4e3599940786
sha256sums = 34c5f2be48639dcd8ec9f38f950916a394ae399a0e583fbde4020acdccf951e0
pkgname = sqlcl
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 48a956f942dd..a9ef03102f24 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,52 @@
# SQLcl Release Notes 23.1.0.089.0929
+## New Features in 23.2.0
+
+### Named Connections
+
+The connmgr command manages a collection of connections. It allows you to list, show, test and clone connections. It also allows you to import connections from Oracle SQL Developer.
+
+```sh
+connmgr import <sql-developer-connections.xml>
+connmgr list <connection 1> ... <connection n>
+
+connmgr show <connection-name> USER: hr URL: jdbc:oracle:thin:@//hostname:1521/ORCL
+
+connmgr connmgr test DB213P Oracle Database 21c Enterprise Edition Release 21.0.0.0.0 - Production Connection Test Successful
+
+connmgr clone -ORIGINAL DB213P clone ``` connmgr list ... clone ...
+```
+
+### Saved Connections
+
+The Connect command has been further expanded to include functionality to allow a user to save a connection. This has two formats.
+
+While a user is connecting with the connect command, a `-save <connection-name>` parameter is supported which allows the user to name the current connection details used as a named connection.
+Secondly, an existing connection previously created, can also be saved using `connect -save <connection-name>`
+Connect or reconnect with that saved connection using `connect -name <connection-name>`
+
+### OCI DB Metrics
+
+The ocidbmetrics command collects metrics from the Oracle Database Dictionary and sends them to the Oracle Cloud Infrastructure (OCI) Metrics service.
+
+The command facilitates setting up a new user with the necessary permissions and initiates the collection of metrics with a 15 second time interval between iterations.
+
+You must have an OCI profile setup to use this feature
+
+```sh
+ocidbmetrics setup myuser
+ocidbmetrics collect -compartmentId [compartmentId_ocid] -region [region_ocid]
+```
+
+## Issues Fixed in 23.2.0
+
+- PLSQL: SHOW ERRORS PERFORMANCE ISSUES WHEN CONNECTING WITH PECULIAR PASSWORD
+- LIQUIBASE: SQLCL 22.3 HAS \ INSTEAD OF / IN CONTROLLER.XML ON WINDOWS AS COMPARED TO LINUX/UNIX.
+- LIQUIBASE: COMMENTS ADDED TO CONTROLLER.XML FILE IN SQLCL 23.1
+- LIQUIBASE: APEX EXPORT FEEDBACK TO DEPLOYMENT SYSTEM CONVERTS THE NAME TO LOWERCASE
+- LIQUIBASE: SQLCL HAS \ INSTEAD OF / IN CONTROLLER.XML ON WINDOWS AS COMPARED TO LINUX/UNIX.
+- CONNECTIONS: ERROR SHOWN WITH SQLCL WHEN LOGIN.SQL HAS "SHOW CONNECTION"
+
## New features in 23.1.0.089.0929
* New features for 22.4.0
diff --git a/PKGBUILD b/PKGBUILD
index f9bebbcae621..19ad9c777220 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Arne Hoch <arne@derhoch.de>
pkgname=sqlcl
-pkgver='23.1.0.089.0929'
+pkgver='23.2.0.178.1027'
pkgrel=1
pkgdesc='SQL Developer command line interface for Oracle'
arch=('any')
@@ -14,7 +14,7 @@ changelog=CHANGELOG.md
depends=('bash' 'java-runtime>=8')
source=("$pkgname-$pkgver.zip::https://download.oracle.com/otn_software/java/sqldeveloper/$pkgname-$pkgver.zip"
"$pkgname.sh")
-sha256sums=('093f0d752bd9a497e168b7f3de4a3b68ea977bfe5948e2602ad91dd3a0147568'
+sha256sums=('c06a8b955f3cc9826b55b94acde1ba55eadfb048028b5250778f4e3599940786'
'34c5f2be48639dcd8ec9f38f950916a394ae399a0e583fbde4020acdccf951e0')
package() {