summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2021-02-26 00:49:24 +0700
committerGitHub2021-02-25 12:49:24 -0500
commit61929c1993215ae90bd2f16c8f5291d555a08b96 (patch)
tree503bb45016ae28c4f9d5504bf2f5568314908f3a
parent66fcece7184ed83882ef3edea1d201d917dd3b76 (diff)
downloadaur-61929c1993215ae90bd2f16c8f5291d555a08b96.tar.gz
[ardupilot-gazebo-sitl-git] xacro patch (#113)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b90cd1a82d20..a59175c1ffff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ardupilot-gazebo-sitl-git
pkgdesc = Gazebo plugin for Ardupilot's SITL.
- pkgver = r33.a6cc333
+ pkgver = r34.e72ecf5
pkgrel = 1
url = https://ardupilot.org/dev/docs/using-gazebo-simulator-with-sitl.html
arch = x86_64
@@ -10,6 +10,8 @@ pkgbase = ardupilot-gazebo-sitl-git
optdepends = ardupilot-sitl
provides = ardupilot-gazebo-sitl
source = ardupilot-gazebo-stil::git+https://github.com/khancyr/ardupilot_gazebo.git
+ source = xacro.patch::https://github.com/khancyr/ardupilot_gazebo/pull/42.patch
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = ardupilot-gazebo-sitl-git
diff --git a/PKGBUILD b/PKGBUILD
index a5fc1a58cc7f..9fbc61881cf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=ardupilot-gazebo-sitl-git
-pkgver=r33.a6cc333
+pkgver=r34.e72ecf5
pkgrel=1
pkgdesc="Gazebo plugin for Ardupilot's SITL."
arch=('x86_64')
@@ -11,14 +11,21 @@ optdepends=('ardupilot-sitl')
makedepends=('cmake')
provides=('ardupilot-gazebo-sitl')
_pkgname=ardupilot-gazebo-stil
-source=("${_pkgname}::git+https://github.com/khancyr/ardupilot_gazebo.git")
-sha256sums=('SKIP')
+source=("${_pkgname}::git+https://github.com/khancyr/ardupilot_gazebo.git"
+ "xacro.patch"::"https://github.com/khancyr/ardupilot_gazebo/pull/42.patch")
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$_pkgname"
+ patch --forward --strip=1 --input="${srcdir}/xacro.patch"
+}
+
build() {
mkdir -p ${srcdir}/${_pkgname}/build
cd ${srcdir}/${_pkgname}/build