summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2022-12-07 18:26:35 +0100
committerLuca Weiss2022-12-07 18:26:35 +0100
commit61c482698729ff37d623483573140d2c840ff617 (patch)
tree8d246d205ec8ea81fa043f6490f57d49b0bb8261
parent9b5a116dde2c73e1d4eb19f102aa35fb3b4c30c0 (diff)
downloadaur-61c482698729ff37d623483573140d2c840ff617.tar.gz
upgpkg: jellyfin-git 10.8.0.alpha5.r1185.g16fdb127ab-1
jellyfin now uses dotnet-sdk 7
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d8efc0f963a..b5eccc7098e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = jellyfin-git
pkgdesc = The Free Software Media System
- pkgver = 10.8.0.alpha5.r1140.g11707f8f08
+ pkgver = 10.8.0.alpha5.r1185.g16fdb127ab
pkgrel = 1
url = https://github.com/jellyfin/jellyfin
arch = i686
arch = x86_64
arch = armv6h
license = GPL2
- makedepends = dotnet-sdk-6.0
+ makedepends = dotnet-sdk
makedepends = npm
makedepends = git
provides = jellyfin
@@ -26,8 +26,8 @@ pkgbase = jellyfin-git
sha512sums = 45a62b62d97b9a83289d4dfde684163b1bcf340c1921fb958e5a701812c61b392901841940c67e5fa5148783277d5b4dc65ba01d3a22e8f855ea62154ad9be33
pkgname = jellyfin-git
- depends = jellyfin-web-git=10.8.0.alpha5.r1140.g11707f8f08
- depends = jellyfin-server-git=10.8.0.alpha5.r1140.g11707f8f08
+ depends = jellyfin-web-git=10.8.0.alpha5.r1185.g16fdb127ab
+ depends = jellyfin-server-git=10.8.0.alpha5.r1185.g16fdb127ab
pkgname = jellyfin-web-git
pkgdesc = Jellyfin web client
@@ -36,8 +36,8 @@ pkgname = jellyfin-web-git
pkgname = jellyfin-server-git
pkgdesc = Jellyfin server component
- depends = dotnet-runtime-6.0
- depends = aspnet-runtime-6.0
+ depends = dotnet-runtime
+ depends = aspnet-runtime
depends = ffmpeg
depends = sqlite
provides = jellyfin-server
diff --git a/PKGBUILD b/PKGBUILD
index 7adac1df48f3..572f62b51fb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgbase=jellyfin-git
pkgname=(jellyfin-git jellyfin-web-git jellyfin-server-git)
-pkgver=10.8.0.alpha5.r1140.g11707f8f08
+pkgver=10.8.0.alpha5.r1185.g16fdb127ab
pkgrel=1
pkgdesc='The Free Software Media System'
arch=('i686' 'x86_64' 'armv6h')
url='https://github.com/jellyfin/jellyfin'
license=('GPL2')
-makedepends=('dotnet-sdk-6.0' 'npm' 'git')
+makedepends=('dotnet-sdk' 'npm' 'git')
provides=('jellyfin')
conflicts=('jellyfin')
source=('git+https://github.com/jellyfin/jellyfin.git'
@@ -44,8 +44,8 @@ build(){
# Disable dotnet telemetry
export DOTNET_CLI_TELEMETRY_OPTOUT=1
- # Force dotnet to use 6.x when multiple SDKs are installed
- dotnet new globaljson --sdk-version 6.0.0 --roll-forward latestMinor --force
+ # Force dotnet to use 7.x when multiple SDKs are installed
+ dotnet new globaljson --sdk-version 7.0.0 --roll-forward latestMinor --force
dotnet build --configuration Release Jellyfin.Server
# Ideally, this would be run in package() with the --output variable pointing
@@ -65,7 +65,7 @@ package_jellyfin-git() {
package_jellyfin-server-git() {
pkgdesc="Jellyfin server component"
- depends=('dotnet-runtime-6.0' 'aspnet-runtime-6.0' 'ffmpeg' 'sqlite')
+ depends=('dotnet-runtime' 'aspnet-runtime' 'ffmpeg' 'sqlite')
backup=('etc/conf.d/jellyfin')
provides=('jellyfin-server')
conflicts=('jellyfin-server')