summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-04-07 21:20:57 -0400
committerJean Lucas2019-04-07 21:25:41 -0400
commit61e91034205eea9ceb8f2398fcf79816577ad1a6 (patch)
treeced4c2dea8e2fe89f37376cee35551aa090dcd71
parentdcacdf0ad67772767527fdf3e9103fa5a20906a2 (diff)
downloadaur-61e91034205eea9ceb8f2398fcf79816577ad1a6.tar.gz
Correct arch, quote variables, add install file
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
-rw-r--r--filtron.install3
3 files changed, 31 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad9cd5b14db9..68b04fc37142 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,27 @@
# Generated by mksrcinfo v8
-# Tue Jul 10 03:05:49 UTC 2018
+# Mon Apr 8 01:25:13 UTC 2019
pkgbase = filtron
pkgdesc = Filtering reverse-HTTP proxy
pkgver = 0+51+93f8b22
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/asciimoo/filtron
- arch = any
+ install = filtron.install
+ arch = i686
+ arch = x86_64
license = AGPL3
makedepends = git
makedepends = go
optdepends = searx: A privacy-respecting, hackable metasearch engine
- optdepends = searx-git: A privacy-respecting, hackable metasearch engine (Git)
+ optdepends = searx-git: A privacy-respecting, hackable metasearch engine (git)
optdepends = morty: Privacy-aware web content sanitizer proxy-as-a-service
- optdepends = morty-git: Privacy-aware web content sanitizer proxy-as-a-service (Git)
+ optdepends = morty-git: Privacy-aware web content sanitizer proxy-as-a-service (git)
conflicts = filtron-git
source = git+https://github.com/asciimoo/filtron#commit=93f8b22bc42fabb57d8a4c0ce7b7de706e6034b6
- source = rules.json
source = filtron.service
+ source = rules.json
sha512sums = SKIP
- sha512sums = 2668deb746ad361ebe32ea46b361f69c0eaf591b7faebb10dd2de11e114645c5fd726d45bb6aebec5b5bcef8dcad51d4b681a5e4b1ec83f918de4929aa237285
sha512sums = 0b7bbe55b3fd89d589e5662699f93d7aaf3c1d77d29be9cc568f8430e4a2491ba4920ca153f4d887a29da1f51670ec06346809cc5d1f373af540e252feccc799
+ sha512sums = 2668deb746ad361ebe32ea46b361f69c0eaf591b7faebb10dd2de11e114645c5fd726d45bb6aebec5b5bcef8dcad51d4b681a5e4b1ec83f918de4929aa237285
pkgname = filtron
diff --git a/PKGBUILD b/PKGBUILD
index 04dcafc7e607..7ced478c5abb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,25 @@
pkgname=filtron
pkgver=0+51+93f8b22
-pkgrel=2
+_commit=93f8b22bc42fabb57d8a4c0ce7b7de706e6034b6
+pkgrel=3
pkgdesc='Filtering reverse-HTTP proxy'
-arch=(any)
+arch=(i686 x86_64)
url=https://github.com/asciimoo/filtron
license=(AGPL3)
conflicts=(filtron-git)
makedepends=(git go)
optdepends=('searx: A privacy-respecting, hackable metasearch engine'
- 'searx-git: A privacy-respecting, hackable metasearch engine (Git)'
+ 'searx-git: A privacy-respecting, hackable metasearch engine (git)'
'morty: Privacy-aware web content sanitizer proxy-as-a-service'
- 'morty-git: Privacy-aware web content sanitizer proxy-as-a-service (Git)')
-source=(git+$url#commit=93f8b22bc42fabb57d8a4c0ce7b7de706e6034b6
- rules.json
- filtron.service)
-sha512sums=(SKIP
- 2668deb746ad361ebe32ea46b361f69c0eaf591b7faebb10dd2de11e114645c5fd726d45bb6aebec5b5bcef8dcad51d4b681a5e4b1ec83f918de4929aa237285
- 0b7bbe55b3fd89d589e5662699f93d7aaf3c1d77d29be9cc568f8430e4a2491ba4920ca153f4d887a29da1f51670ec06346809cc5d1f373af540e252feccc799)
+ 'morty-git: Privacy-aware web content sanitizer proxy-as-a-service (git)')
+install=filtron.install
+source=(git+$url#commit=$_commit
+ filtron.service
+ rules.json)
+sha512sums=('SKIP'
+ '0b7bbe55b3fd89d589e5662699f93d7aaf3c1d77d29be9cc568f8430e4a2491ba4920ca153f4d887a29da1f51670ec06346809cc5d1f373af540e252feccc799'
+ '2668deb746ad361ebe32ea46b361f69c0eaf591b7faebb10dd2de11e114645c5fd726d45bb6aebec5b5bcef8dcad51d4b681a5e4b1ec83f918de4929aa237285')
pkgver() {
cd filtron
@@ -27,13 +29,15 @@ pkgver() {
build() {
cd filtron
- GOPATH=$srcdir/filtron go get -v -x github.com/asciimoo/filtron
+ GOPATH="$srcdir"/filtron go get -v -x github.com/asciimoo/filtron
}
package() {
+ install -Dm 644 filtron.service -t "$pkgdir"/usr/lib/systemd/system
+ install -Dm 644 rules.json -t "$pkgdir"/etc/filtron
+
cd filtron
- install -D bin/filtron $pkgdir/usr/bin/filtron
- install -Dm 644 ../rules.json $pkgdir/etc/filtron/rules.json
- install -Dm 644 ../filtron.service $pkgdir/usr/lib/systemd/system/filtron.service
- install -Dm 644 LICENSE $pkgdir/usr/share/licenses/filtron/LICENSE
+
+ install -D bin/filtron -t "$pkgdir"/usr/bin
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/filtron
}
diff --git a/filtron.install b/filtron.install
new file mode 100644
index 000000000000..5dae544d5dae
--- /dev/null
+++ b/filtron.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "By default, Filtron listens on 127.0.0.1:4004, uses the rules at /etc/filtron/rules.json, and targets 127.0.0.1:8888. Change these settings at /usr/lib/systemd/system/filtron.service"
+}