summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-08-05 09:33:03 -0600
committerMark Wagie2023-08-05 09:33:03 -0600
commit61e95d8d5a02a78b40c916b18238a768c58f73f7 (patch)
tree98423a5e187be8b32bd1bbdaa496bb0c38fa84cd
parenta50660e84a0925910afaed310462ad4592494511 (diff)
downloadaur-61e95d8d5a02a78b40c916b18238a768c58f73f7.tar.gz
relax requirements
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 925b37862677..8793b8ee59bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-userspacefs
pkgdesc = Cross-platform user-space file systems for Python
pkgver = 2.0.5
- pkgrel = 4
+ pkgrel = 5
url = https://thelig.ht/code/userspacefs
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index a7298bf82c26..4cf0f76ea5fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-userspacefs
_name=${pkgname#python-}
pkgver=2.0.5
-pkgrel=4
+pkgrel=5
pkgdesc="Cross-platform user-space file systems for Python"
arch=('any')
url="https://thelig.ht/code/userspacefs"
@@ -12,6 +12,15 @@ makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('5d6f5ffa6d39488f1c7437c5eaae8fabf4916caceab483a3173a18e6789b186c')
+prepare() {
+ cd "$_name-$pkgver"
+
+ # Relax requirements
+ for f in setup.py "$_name.egg-info/requires.txt" ; do
+ sed -i 's/fusepyng>=1.0.7,<2/fusepyng>=1.0.7/g' "${f}"
+ done
+}
+
build() {
cd "$_name-$pkgver"
python -m build --wheel --no-isolation