summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-10-04 11:45:32 +0800
committerlilac2020-10-04 11:45:32 +0800
commit61edcdebd0ce9f2ef428488292ad538f99465127 (patch)
tree722f0b3d0b3b8fa21a91e3623bbabe3b45b55ebc
parentd3c190c6e98d04bcf7fe8ff3d5fece282e571ebb (diff)
downloadaur-61edcdebd0ce9f2ef428488292ad538f99465127.tar.gz
[lilac] updated to 7.6.1.r0.gcd1b78d-2
-rw-r--r--.SRCINFO17
-rw-r--r--Adapt-for-new-libcpuid-structure.patch18
-rw-r--r--Fix-error-if-proc-mtrr-doesn-t-exist.patch28
-rw-r--r--Fix-libcpuid-SOVERSION.patch19
-rw-r--r--PKGBUILD37
5 files changed, 99 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28d590bbde8f..b7681711e79a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
-# Generated by mksrcinfo v8
-# Mon Sep 18 20:56:18 UTC 2017
pkgbase = i-nex-git
pkgdesc = System information tool like hardinfo, sysinfo
- pkgver = 7.6.0.r61.g0c10102
- pkgrel = 3
+ pkgver = 7.6.1.r0.gcd1b78d
+ pkgrel = 2
url = http://i-nex.linux.pl/
arch = i686
arch = x86_64
license = LGPL3
+ makedepends = git
makedepends = gambas3-devel
makedepends = gcc
makedepends = imagemagick
- makedepends = git
depends = gambas3-runtime
depends = gambas3-gb-image
depends = gambas3-gb-form
@@ -22,7 +20,6 @@ pkgbase = i-nex-git
depends = libcpuid-git
depends = lsb-release
depends = curl
- depends = pastebinit
depends = procps-ng
provides = i-nex
conflicts = i-nex
@@ -37,8 +34,14 @@ pkgbase = i-nex-git
backup = etc/i-nex/Database/intel.json
backup = etc/i-nex/Database/Opteron.json
backup = etc/i-nex/Database/Xeon.json
- source = i-nex-git::git://github.com/eloaders/I-Nex.git
+ source = i-nex::git+https://github.com/i-nex/I-Nex.git
+ source = Fix-error-if-proc-mtrr-doesn-t-exist.patch
+ source = Fix-libcpuid-SOVERSION.patch
+ source = Adapt-for-new-libcpuid-structure.patch
sha256sums = SKIP
+ sha256sums = 5c812da66cf8627e1749722d8e98f0871e6b3dbc30efbce29b785912ff39e96b
+ sha256sums = a6cee05fcf07c2d2ddbabd4012a3975178c07e0f9d1e876425567d9504eb99cd
+ sha256sums = fb286cf3bc0b1104e59219e0ba9a236129b20db52b70cd44d65f578404a93cbe
pkgname = i-nex-git
diff --git a/Adapt-for-new-libcpuid-structure.patch b/Adapt-for-new-libcpuid-structure.patch
new file mode 100644
index 000000000000..f6cdfade5509
--- /dev/null
+++ b/Adapt-for-new-libcpuid-structure.patch
@@ -0,0 +1,18 @@
+---
+ I-Nex/i-nex/.src/CPU/MLibcpuid14.module | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/I-Nex/i-nex/.src/CPU/MLibcpuid14.module b/I-Nex/i-nex/.src/CPU/MLibcpuid14.module
+index 8df4621..8c9cd2f 100644
+--- a/I-Nex/i-nex/.src/CPU/MLibcpuid14.module
++++ b/I-Nex/i-nex/.src/CPU/MLibcpuid14.module
+@@ -11,6 +11,7 @@ Public Struct cpu_raw_data_t
+ intel_fn11[4, 4] As Integer
+ intel_fn12h[4, 4] As Integer
+ intel_fn14h[4, 4] As Integer
++ amd_fn8000001dh[4, 4] As Integer
+ End Struct
+
+ Public Struct cpu_mark_t
+--
+2.26.2
diff --git a/Fix-error-if-proc-mtrr-doesn-t-exist.patch b/Fix-error-if-proc-mtrr-doesn-t-exist.patch
new file mode 100644
index 000000000000..502b950ab4c2
--- /dev/null
+++ b/Fix-error-if-proc-mtrr-doesn-t-exist.patch
@@ -0,0 +1,28 @@
+---
+ Finfosys.class | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/I-Nex/i-nex/.src/MAIN/Finfosys.class b/I-Nex/i-nex/.src/MAIN/Finfosys.class
+index c2778eb..cccc602 100644
+--- a/I-Nex/i-nex/.src/MAIN/Finfosys.class
++++ b/I-Nex/i-nex/.src/MAIN/Finfosys.class
+@@ -66,6 +66,8 @@ Public Sub Form_Open()
+ Logs("Call to MLibcpuid14", Logger.Info)
+ Object.Call(MLibcpuid14, "main")
+
++ If False Then
++
+ Try data = Open "/proc/mtrr" For Input
+
+ While Not Eof(data)
+@@ -75,6 +77,8 @@ Public Sub Form_Open()
+ Wend
+
+ Try Close #data
++
++ Endif
+
+ ' If Exist("/proc/mtrr", True) Then
+ ' For i = 1 To MaxCount
+--
+2.25.1
diff --git a/Fix-libcpuid-SOVERSION.patch b/Fix-libcpuid-SOVERSION.patch
new file mode 100644
index 000000000000..943478fd5998
--- /dev/null
+++ b/Fix-libcpuid-SOVERSION.patch
@@ -0,0 +1,19 @@
+---
+ I-Nex/i-nex/.src/CPU/MLibcpuid14.module | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/I-Nex/i-nex/.src/CPU/MLibcpuid14.module b/I-Nex/i-nex/.src/CPU/MLibcpuid14.module
+index 743b9d2..8df4621 100644
+--- a/I-Nex/i-nex/.src/CPU/MLibcpuid14.module
++++ b/I-Nex/i-nex/.src/CPU/MLibcpuid14.module
+@@ -2,7 +2,7 @@
+
+ ' The module was written by vuott from http://www.gambas-it.org/
+ ' http://www.gambas-it.org/smf/index.php?action=profile;u=402
+-Library "libcpuid:14.0.1"
++Library "libcpuid:15"
+
+ Public Struct cpu_raw_data_t
+ basic_cpuid[32, 4] As Integer
+--
+2.26.2
diff --git a/PKGBUILD b/PKGBUILD
index 92ae08ab1ea4..2db5c3362161 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Based on the PKGBUILD from eloaders <eloaders at linux dot pl>
pkgname=i-nex-git
-pkgver=7.6.0.r61.g0c10102
-pkgrel=3
+_pkgname=i-nex
+pkgver=7.6.1.r0.gcd1b78d
+pkgrel=2
pkgdesc="System information tool like hardinfo, sysinfo"
arch=('i686' 'x86_64')
url="http://i-nex.linux.pl/"
@@ -18,13 +19,18 @@ depends=('gambas3-runtime'
'libcpuid-git'
'lsb-release'
'curl'
- 'pastebinit'
'procps-ng')
-makedepends=('gambas3-devel' 'gcc' 'imagemagick' 'git')
-source=($pkgname::'git://github.com/eloaders/I-Nex.git')
-sha256sums=('SKIP')
-provides=('i-nex')
+makedepends=('git' 'gambas3-devel' 'gcc' 'imagemagick')
+source=(${_pkgname}::"git+https://github.com/i-nex/I-Nex.git"
+ "Fix-error-if-proc-mtrr-doesn-t-exist.patch"
+ "Fix-libcpuid-SOVERSION.patch"
+ "Adapt-for-new-libcpuid-structure.patch")
+sha256sums=('SKIP'
+ '5c812da66cf8627e1749722d8e98f0871e6b3dbc30efbce29b785912ff39e96b'
+ 'a6cee05fcf07c2d2ddbabd4012a3975178c07e0f9d1e876425567d9504eb99cd'
+ 'fb286cf3bc0b1104e59219e0ba9a236129b20db52b70cd44d65f578404a93cbe')
conflicts=('i-nex')
+provides=('i-nex')
backup=('etc/i-nex/Database/i2c/devices.json'
'etc/i-nex/Database/A6.json'
'etc/i-nex/Database/amd.json'
@@ -38,12 +44,17 @@ backup=('etc/i-nex/Database/i2c/devices.json'
'etc/i-nex/Database/Xeon.json')
pkgver() {
- cd $pkgname
+ cd $_pkgname
git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {
- cd $pkgname
+ cd "${srcdir}/${_pkgname}"
+
+ patch -Np1 -i "${srcdir}/Fix-error-if-proc-mtrr-doesn-t-exist.patch"
+ patch -Np1 -i "${srcdir}/Fix-libcpuid-SOVERSION.patch"
+ patch -Np1 -i "${srcdir}/Adapt-for-new-libcpuid-structure.patch"
+
sed -i -e 's|^STATIC.*|STATIC = false|' i-nex.mk
sed -i -e 's|^UDEV_RULES_DIR.*|UDEV_RULES_DIR = /usr/lib/udev/rules.d|' i-nex.mk
cd "I-Nex"
@@ -51,14 +62,14 @@ prepare() {
}
build() {
- cd $pkgname
+ cd "${srcdir}/${_pkgname}"
cd "I-Nex"
./configure --prefix=/usr
cd ..
- make -j1
+ MAGICK_OCL_DEVICE=OFF make -j1
}
package() {
- cd $pkgname
- make -j1 DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/${_pkgname}"
+ MAGICK_OCL_DEVICE=OFF make -j1 DESTDIR="${pkgdir}/" install
}