summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-08-02 20:07:45 +0300
committerIgor Dyatlov2021-08-02 20:07:45 +0300
commit61ee6e03061d794ce14392d88d3c37de9c86e19c (patch)
tree8fe00373725767f62e44d31f12da2f7c8ac58f73
downloadaur-61ee6e03061d794ce14392d88d3c37de9c86e19c.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bead4f14ba2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = banner-viewer
+ pkgdesc = View and edit GNOME Software banners
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://gitlab.gnome.org/World/design/banner-viewer
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = meson
+ makedepends = rust
+ depends = gtk3
+ depends = glib2
+ depends = gdk-pixbuf2
+ depends = libhandy
+ depends = gtksourceview3
+ source = https://gitlab.gnome.org/World/design/banner-viewer/-/archive/0.0.1/banner-viewer-0.0.1.tar.gz
+ sha256sums = SKIP
+
+pkgname = banner-viewer
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f102325bab3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=banner-viewer
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="View and edit GNOME Software banners"
+arch=('any')
+url="https://gitlab.gnome.org/World/design/$pkgname"
+license=('GPL')
+depends=('gtk3' 'glib2' 'gdk-pixbuf2' 'libhandy' 'gtksourceview3')
+makedepends=('git' 'meson' 'rust')
+source=("https://gitlab.gnome.org/World/design/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('SKIP') #autofill using updpkgsums
+
+build() {
+ arch-meson "$pkgname-$pkgver" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+} \ No newline at end of file