summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTiago Koji Castro Shibata2018-02-07 14:05:48 -0200
committerTiago Koji Castro Shibata2018-02-08 14:51:05 -0200
commit6240d9bd1823e90e51705b908aeb375cbafbe465 (patch)
treebe1d5a63eeb44c1bfe70aaf9b8a3d5b02023d8ef
downloadaur-6240d9bd1823e90e51705b908aeb375cbafbe465.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cfc92cd5d40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lm4flash-git
+ pkgdesc = Firmware flashing tool for Stellaris Launchpad ICDI
+ pkgver = v0.1.2.r14.g65fbc45
+ pkgrel = 1
+ url = https://github.com/utzig/lm4tools
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ depends = libusb
+ provides = lm4flash
+ conflicts = lm4flash
+ source = git+https://github.com/utzig/lm4tools.git
+ md5sums = SKIP
+
+pkgname = lm4flash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..470d2bcfbe78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Tiago Koji Castro Shibata <tiago.shibata@gmail.com>
+pkgname=lm4flash-git
+pkgver=v0.1.2.r14.g65fbc45
+pkgrel=1
+pkgdesc="Development tools fot the TI Launchpad boards"
+arch=('x86_64' 'i686')
+url="https://github.com/utzig/lm4tools"
+license=('GPL')
+depends=('libusb')
+makedepends=('git')
+provides=('lm4flash')
+conflicts=('lm4flash')
+source=('git+https://github.com/utzig/lm4tools.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd lm4tools
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "lm4tools/lm4flash"
+ make
+}
+
+package() {
+ install -Dm755 lm4tools/lm4flash/lm4flash "$pkgdir/usr/bin/lm4flash"
+}