summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan Knížek2015-06-24 13:06:54 +0200
committerMilan Knížek2015-06-24 13:06:54 +0200
commit62696243fb5a947452ae2d020cc36ecc5b5c3a76 (patch)
tree4a1a4ed2dbe067fc002b4134663657de4457ac17
downloadaur-62696243fb5a947452ae2d020cc36ecc5b5c3a76.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD71
-rw-r--r--sharetray.cpp.patch210
-rw-r--r--x2godesktopsharing.install26
4 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c69d6377ec15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = x2godesktopsharing
+ pkgdesc = x2godesktopsharing is an X2Go add-on tool that allows a user to grant other X2go users access to the current session (shadow session support).
+ pkgver = 3.1.1.2
+ pkgrel = 2
+ url = http://www.x2go.org/
+ install = x2godesktopsharing.install
+ arch = i686
+ arch = x86_64
+ groups = x2go
+ groups = alts
+ license = GPL
+ depends = x2goserver>=4.0.1
+ depends = qt4>=4.5
+ options = !strip
+ source = sharetray.cpp.patch2
+ source = http://code.x2go.org/releases/source/x2godesktopsharing/x2godesktopsharing-3.1.1.2.tar.gz
+ md5sums = 83c1d72798534d60a2fcc2d21713cd83
+ md5sums = bd48394f5a4eaa55559622f21a5e0a79
+
+pkgname = x2godesktopsharing
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40ab22146cbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Submitter: Milan Knížek <knizek@volny.cz>
+# Maintainer: Milan Knížek <knizek@volny.cz>
+
+pkgname=x2godesktopsharing
+pkgver=3.1.1.2
+pkgrel=2
+pkgdesc="x2godesktopsharing is an X2Go add-on tool that allows a user to grant other X2go users access to the current session (shadow session support)."
+arch=('i686' 'x86_64')
+url="http://www.x2go.org/"
+license=('GPL')
+depends=('x2goserver>=4.0.1' 'qt4>=4.5')
+options=(emptydirs)
+install=$pkgname.install
+groups=('x2go' 'alts')
+options=(!strip)
+source=('sharetray.cpp.patch2'
+ "http://code.x2go.org/releases/source/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('83c1d72798534d60a2fcc2d21713cd83'
+ 'bd48394f5a4eaa55559622f21a5e0a79')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+# echo "CONFIG = qt x11 dll debug" >> x2godesktopsharing.pro
+ patch -p0 < ../sharetray.cpp.patch2
+ qmake-qt4 x2godesktopsharing.pro
+# cp ../Makefiledbg Makefile
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D -m 755 x2godesktopsharing "$pkgdir/usr/bin/x2godesktopsharing"
+ install -m 755 bin/x2goresume-desktopsharing "$pkgdir/usr/bin/x2goresume-desktopsharing"
+ install -m 755 bin/x2gosuspend-desktopsharing "$pkgdir/usr/bin/x2gosuspend-desktopsharing"
+ install -m 755 bin/x2goterminate-desktopsharing "$pkgdir/usr/bin/x2goterminate-desktopsharing"
+
+ install -d -m 755 "$pkgdir/usr/share/applications"
+ install -m 644 x2godesktopsharing.desktop "$pkgdir/usr/share/applications/x2godesktopsharing.desktop"
+
+ install -d -m 755 "$pkgdir/usr/share/x2godesktopsharing/icons"
+ install -m 644 icons/x2godesktopsharing.xpm "$pkgdir/usr/share/x2godesktopsharing/icons/x2godesktopsharing.xpm"
+
+ install -d -m 755 "$pkgdir/usr/share/icons/hicolor/128x128/apps"
+ install -m 644 icons/128x128/x2godesktopsharing.png "$pkgdir/usr/share/icons/hicolor/128x128/apps/x2godesktopsharing.png"
+
+ install -d -m 755 "$pkgdir/usr/share/icons/hicolor/16x16/apps"
+ install -m 644 icons/16x16/x2godesktopsharing.png "$pkgdir/usr/share/icons/hicolor/16x16/apps/x2godesktopsharing.png"
+
+ install -d -m 755 "$pkgdir/usr/share/icons/hicolor/64x64/apps"
+ install -m 644 icons/64x64/x2godesktopsharing.png "$pkgdir/usr/share/icons/hicolor/64x64/apps/x2godesktopsharing.png"
+
+ install -d -m 755 "$pkgdir/usr/share/icons/hicolor/32x32/apps"
+ install -m 644 icons/32x32/x2godesktopsharing.png "$pkgdir/usr/share/icons/hicolor/32x32/apps/x2godesktopsharing.png"
+
+ gzip man/man1/x2godesktopsharing.1
+ install -d -m 755 "$pkgdir/usr/share/man/man1"
+ install -m 644 -t "$pkgdir/usr/share/man/man1" man/man1/x2go*.gz
+
+ gzip man/man8/x2go*-desktopsharing.8
+ install -d -m 755 "$pkgdir/usr/share/man/man8"
+ install -m 644 -t "$pkgdir/usr/share/man/man8" man/man8/x2go*-desktopsharing.8.gz
+
+ install -d -m 755 "$pkgdir/usr/share/menu"
+
+ install -d -m 755 -d "${pkgdir}/usr/share/doc/${pkgname}"
+
+ install -d -m 755 "${pkgdir}/usr/share/x2go/versions/"
+ echo ${pkgver} > "${pkgdir}/usr/share/x2go/versions/VERSION.$pkgname"
+
+ install -D -m 755 "share/x2gofeature.d/x2godesktopsharing.features" "${pkgdir}/usr/share/x2go/x2gofeature.d/x2godesktopsharing.features"
+}
diff --git a/sharetray.cpp.patch2 b/sharetray.cpp.patch2
new file mode 100644
index 000000000000..ecc0b0c813e9
--- /dev/null
+++ b/sharetray.cpp.patch2
@@ -0,0 +1,10 @@
+--- sharetray.cpp 2012-02-19 20:18:22.055004155 +0100
++++ sharetray.cpp_mod 2012-02-19 20:31:48.852666353 +0100
+@@ -171,6 +171,7 @@
+
+
+ actStop->setEnabled ( false );
++ slotStartSharing();
+
+ // unix signals (TERM, INT) are piped into a unix socket and will raise Qt events
+ if (::socketpair(AF_UNIX, SOCK_STREAM, 0, sigkeybintFd))
diff --git a/x2godesktopsharing.install b/x2godesktopsharing.install
new file mode 100644
index 000000000000..f285d7c6a435
--- /dev/null
+++ b/x2godesktopsharing.install
@@ -0,0 +1,26 @@
+post_install()
+{
+ # setup x2godesktopsharing group
+ if ! getent group x2godesktopsharing >/dev/null; then
+ groupadd -K GID_MIN=800 -K GID_MAX=999 x2godesktopsharing
+ echo " ==> Group x2godesktopsharing created."
+ echo " Adding users to x2godesktopsharing ('gpasswd -a \$USER x2godesktopsharing')"
+ echo " will allow them to access their current local desktop remotely (shadowing)."
+ fi
+}
+
+post_upgrade()
+{
+ post_install
+ warning
+}
+
+warning()
+{
+ # Check if the originally used "x2godesktopshare" still exists and propose migration.
+ # The sys user should take care about (delete) the obsolete group manually.
+ if getent group x2godesktopshare >/dev/null; then
+ echo " The obsolete group x2godesktopshare exists. Pls migrate users to the group"
+ echo " x2godesktopsharing instead and remove this obsolete one."
+ fi
+}