summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLancia2022-10-29 01:03:34 +0330
committerLancia2022-10-29 01:03:34 +0330
commit626ac6d92868220cbc84ab1ab916f8188c1eb639 (patch)
tree222f763eaff0cbf9db7ad5853e87a7f59e58172b
parent77a58ed6f9348c0543b552343fe5d317f234c633 (diff)
downloadaur-626ac6d92868220cbc84ab1ab916f8188c1eb639.tar.gz
First package release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
2 files changed, 31 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bab428fd011..3cd90dc81701 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,16 @@
pkgbase = herbe-git
- pkgver = 1
- pkgrel = 1
- url = https://github.com/dudik/herbe
- arch = any
- license = MIT
- makedepends = git
- source = git+https://github.com/dudik/herbe.git
- md5sums = SKIP
+ pkgdesc = Daemon-less notifications without D-Bus
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/dudik/herbe
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = libx11
+ depends = libxft
+ provides = herbe
+ conflicts = herbe
+ source = herbe-git-1.0.0::git+https://github.com/dudik/herbe
+ md5sums = SKIP
pkgname = herbe-git
diff --git a/PKGBUILD b/PKGBUILD
index c84613518ca8..63758e746b44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,25 @@
-# Maintainer: Samuel Dudík <dudik at tutanota dot com>
-_pkgname=herbe
-pkgname=$_pkgname-git
-pkgver=1
-pkgrel=1
-pkgdesc="Daemon-less notifications without D-Bus. Minimal and lightweight."
-arch=(any)
+# Maintainer: Lancia Greggori <lanciagreggori@gmail.com>
+pkgname='herbe-git'
+pkgver='1.0.0'
+pkgrel='1'
+pkgdesc='Daemon-less notifications without D-Bus'
+arch=('x86_64')
+url='https://github.com/dudik/herbe'
license=('MIT')
+depends=('libx11' 'libxft')
makedepends=('git')
-url="https://github.com/dudik/$_pkgname"
-source=("git+https://github.com/dudik/$_pkgname.git")
+provides=('herbe')
+conflicts=('herbe')
+source=("$pkgname-$pkgver::git+$url")
md5sums=('SKIP')
-prepare() {
- cd $_pkgname
- if [ -f "$srcdir/config.h" ]; then
- cp -f "$srcdir/config.h" config.h
- fi
+build() {
+ cd "$pkgname-$pkgver"
+ make clean all
}
-build () {
- cd "$_pkgname"
- make
-}
-
-package () {
- cd "$_pkgname"
- mkdir -p "$pkgdir/usr/local/bin"
- cp $_pkgname "$pkgdir/usr/local/bin/"
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX='/usr' DESTDIR="$pkgdir/" install
+ install -D -m 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}