summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2016-05-02 22:19:53 -0700
committerRich Li2016-05-02 22:19:53 -0700
commit628d3c22628d2f1c45a1b4d38a1cde8ac4a155a0 (patch)
treee3496a7c6d3d062711e7f3f989743d9ed870a75f
parent8acfde29b38c2c95bfb0ab1454909454dee52fa0 (diff)
downloadaur-628d3c22628d2f1c45a1b4d38a1cde8ac4a155a0.tar.gz
Check the test suite
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d14819854366..42dd21b0e628 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,17 +19,10 @@ build() {
python2 setup.py build --with-cython
}
-# pyvenv is python 3.4 only, so this has to be updated for python 2.7
-# check() {
-# cd "$srcdir/cyordereddict-$pkgver"
-#
-# # We use pyvenv to create a virtual environment where the package will be installed, then we can test it. Note that we symlink to the system site-packages so we have (read-only) access to nosetests.
-# pyvenv arch_test --system-site-packages
-# _venv_python="arch_test/bin/python"
-#
-# ${_venv_python} setup.py install
-# ${_venv_python} $(which nosetests) cyordereddict ./python3/cyordereddict/test
-# }
+check() {
+ cd "$srcdir/cyordereddict-$pkgver/build/lib.linux-${CARCH}-2.7"
+ nosetests2
+}
package() {
cd "$srcdir/cyordereddict-$pkgver"