summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 16:05:19 +0200
committersl1pkn072015-06-08 16:05:19 +0200
commit62a133c823bdd05988f5aa1d01a00b1f21b6e5a2 (patch)
treee67f905c6c790867dbef99a2cd5f11bade1b8684
downloadaur-62a133c823bdd05988f5aa1d01a00b1f21b6e5a2.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
-rw-r--r--danbooru-client-git.install12
4 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a75badf1555
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = danbooru-client-git
+ pkgdesc = Application to access Danbooru-based image boards. (GIT Version)
+ pkgver = v0.3.0.21.gef46a37
+ pkgrel = 1
+ url = http://www.dennogumi.org/projects/danbooru-client
+ install = danbooru-client-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = python
+ depends = kdeclarative
+ depends = kfilemetadata
+ provides = danbooru-client
+ conflicts = danbooru-client
+ source = git+https://git.dennogumi.org/kde/danbooru-client.git
+ sha1sums = SKIP
+
+pkgname = danbooru-client-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c848ef4cac39
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!danbooru-client-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5e0a550fc66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: archtux <antonio dot arias99999 at gmail dot com>
+
+pkgname=danbooru-client-git
+pkgver=v0.3.0.21.gef46a37
+pkgrel=1
+pkgdesc="Application to access Danbooru-based image boards. (GIT Version)"
+url="http://www.dennogumi.org/projects/danbooru-client"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('kdeclarative' 'kfilemetadata')
+makedepends=('git' 'cmake' 'extra-cmake-modules' 'python')
+conflicts=('danbooru-client')
+provides=('danbooru-client')
+source=("git+https://git.dennogumi.org/kde/danbooru-client.git")
+sha1sums=('SKIP')
+install=danbooru-client-git.install
+
+pkgver() {
+ cd danbooru-client
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../danbooru-client \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+} \ No newline at end of file
diff --git a/danbooru-client-git.install b/danbooru-client-git.install
new file mode 100644
index 000000000000..a188eff066bd
--- /dev/null
+++ b/danbooru-client-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+