summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2013-02-12 19:10:39 +0100
committerJohannes Dewender2013-02-12 19:10:39 +0100
commit62a510c0a71e6be6d95f0bcf5336fccc175f9fb5 (patch)
treed07c794128e07b7f64e2f4de7468a69f37f82a4d
downloadaur-62a510c0a71e6be6d95f0bcf5336fccc175f9fb5.tar.gz
pyhon2-debianbts: add as 1.10
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD27
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b093857d970a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-debianbts
+ pkgdesc = Python interface to Debians Bug Tracking System
+ pkgver = 1.10
+ pkgrel = 1
+ url = http://packages.debian.org/sid/python-debianbts
+ arch = any
+ license = GPL2
+ depends = python2-soappy
+ depends = python2-support
+ options = !emptydirs
+ source = http://pypi.python.org/packages/source/p/python-debianbts/python-debianbts-1.10.tar.gz
+ md5sums = 828d82eaa8884b51b29343c30de9458b
+
+pkgname = python2-debianbts
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd9b4a41adc0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.rpm
+*.zip
+*.bz2
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15e582a87373
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Johannes Dewender arch at JonnyJD dot net
+pkgname=python2-debianbts
+_pkgname=python-debianbts
+_python=python2
+pkgver=1.10
+pkgrel=1
+pkgdesc="Python interface to Debians Bug Tracking System"
+arch=('any')
+url="http://packages.debian.org/sid/python-debianbts"
+license=('GPL2')
+depends=('python2-soappy' 'python2-support')
+makedepends=()
+conflicts=()
+options=(!emptydirs)
+source=(http://pypi.python.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz)
+md5sums=('828d82eaa8884b51b29343c30de9458b')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ $_python setup.py build
+}
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ $_python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: