summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrần Nam Tuấn2023-07-29 11:54:19 +0700
committerTrần Nam Tuấn2023-07-29 11:54:19 +0700
commit62a520e7fb9b5c0c6e6de5a212ef73156b637b1d (patch)
tree7ed5d3dd8df0d4a5b1916e6b8bd066d912f6f6b9
parent9c24855dd48654682e448b5c63132acde15b8b36 (diff)
downloadaur-62a520e7fb9b5c0c6e6de5a212ef73156b637b1d.tar.gz
Set CMake to build using Qt6
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD9
3 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc8be9d66041..229ccce496f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtcreator-spellchecker-plugin-git
pkgdesc = Spell Checker plugin for the Qt Creator IDE
- pkgver = v3.1.2.r0.g6449d12
- pkgrel = 3
+ pkgver = 3.4.0.r2.g83277fc
+ pkgrel = 1
url = https://github.com/CJCombrink/SpellChecker-Plugin
arch = i686
arch = x86_64
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..49ae415e820b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.tar.zst
+*.tar.gz
+qtcreator-spellchecker-plugin-git/
diff --git a/PKGBUILD b/PKGBUILD
index 56c8ce38e717..62054f7bba92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: TheBill2001 <tuantran1632001 at gmail dot com>
pkgname=qtcreator-spellchecker-plugin-git
-pkgver=v3.1.2.r0.g6449d12
-pkgrel=3
+pkgver=3.4.0.r2.g83277fc
+pkgrel=1
pkgdesc="Spell Checker plugin for the Qt Creator IDE"
groups=('qt')
arch=('i686' 'x86_64')
@@ -18,7 +18,7 @@ sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -26,7 +26,8 @@ build() {
-S ${pkgname}\
-B build \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQT_DIR=/usr/lib/cmake/Qt6
cmake --build build
}