summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2018-11-02 16:48:06 +0800
committerpingplug2018-11-02 16:48:06 +0800
commit62d1aaff204f01b9facff8df4c8d5957477e72c4 (patch)
treed5a8edc91ad789f41f424fb8ffef1ab9741a584e
parent2c78c4702271f4886361e763f869172bbfc0e88b (diff)
downloadaur-62d1aaff204f01b9facff8df4c8d5957477e72c4.tar.gz
remove fdk-aac
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
-rw-r--r--dep.patch33
3 files changed, 14 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7c73a3617f5..03506fafd93d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cin-git
pkgdesc = Cinelerra maintained by Good Guy (git version)
- pkgver = 5.1.20180630
+ pkgver = 5.1.20181031
pkgrel = 1
url = https://cinelerra-cv.org
arch = x86_64
@@ -27,7 +27,6 @@ pkgbase = cin-git
depends = libavc1394
depends = libdatrie
depends = libdv
- depends = libfdk-aac
depends = libffi
depends = libglvnd
depends = libiec61883
@@ -55,7 +54,7 @@ pkgbase = cin-git
source = cinelerra-gg::git+git://git.cinelerra-cv.org/goodguy/cinelerra.git
source = dep.patch
sha256sums = SKIP
- sha256sums = 9d4a2a8c21f0c3632317d9b3f6f88d96d544dc08a487cd8efadbcf3dfc18269e
+ sha256sums = d48f53dc4f5ee2adc77b1d6f27cc2763e21cad4f4d5939f8e59720dd3427c04f
pkgname = cin-git
diff --git a/PKGBUILD b/PKGBUILD
index b47506920429..3dc62c55f964 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ _pkgname=cinelerra-gg
_pkgver=5.1
pkgname=cin-git
-pkgver=5.1.20180630
+pkgver=5.1.20181031
pkgrel=1
pkgdesc="Cinelerra maintained by Good Guy (git version)"
arch=('x86_64')
@@ -29,7 +29,6 @@ depends=('alsa-lib'
'libavc1394'
'libdatrie'
'libdv'
- 'libfdk-aac'
'libffi'
'libglvnd'
'libiec61883'
@@ -65,7 +64,7 @@ makedepends=('yasm'
source=("${_pkgname}::git+git://git.cinelerra-cv.org/goodguy/cinelerra.git"
"dep.patch")
sha256sums=('SKIP'
- '9d4a2a8c21f0c3632317d9b3f6f88d96d544dc08a487cd8efadbcf3dfc18269e')
+ 'd48f53dc4f5ee2adc77b1d6f27cc2763e21cad4f4d5939f8e59720dd3427c04f')
pkgver() {
cd "${srcdir}/${_pkgname}/cinelerra-${_pkgver}/blds"
@@ -76,14 +75,13 @@ prepare() {
cd "${srcdir}"
# Patches
# 1. do not build libvorbis when libvorbis is installed
- # 2. fix wrong fdk-aac detection
- # 3. fix wrong openexr detection
- # 4. fix wrong pkg-config definition
+ # 2. fix wrong openexr detection
+ # 3. fix wrong pkg-config definition
patch -Np0 -i dep.patch
cd "${srcdir}/${_pkgname}/cinelerra-${_pkgver}"
- sed -i 's/\<python\>/python2.7/' ./guicast/Makefile
- ./autogen.sh
+ #sed -i 's/\<python\>/python2.7/' ./guicast/Makefile
+ #./autogen.sh
}
build() {
diff --git a/dep.patch b/dep.patch
index f4c81f39831b..385f2aa27880 100644
--- a/dep.patch
+++ b/dep.patch
@@ -1,16 +1,7 @@
diff -ruN cinelerra-gg/cinelerra-5.1/configure.ac cinelerra-gg-new/cinelerra-5.1/configure.ac
---- cinelerra-gg/cinelerra-5.1/configure.ac 2018-06-28 16:38:54.885096000 +0800
-+++ cinelerra-gg-new/cinelerra-5.1/configure.ac 2018-06-28 16:41:45.598921556 +0800
-@@ -525,7 +525,7 @@
- CHECK_HEADERS([encore], [encore headers], [encore.h])
- CHECK_LIB([giflib], [gif], [DGifOpen])
- CHECK_HEADERS([giflib], [gif lib headers], [gif_lib.h])
--CHECK_LIB([fdk], [fdk-aac], [faacDecInit])
-+CHECK_LIB([fdk], [fdk-aac], [aacDecoder_AncDataInit])
- CHECK_HEADERS([fdk], [fdk headers], [fdk-aac/genericStds.h])
- CHECK_LIB([jbig], [jbig], [jbg_dec_init])
- CHECK_LIB([vdpau], [vdpau], [vdp_device_create_x11])
-@@ -649,8 +649,8 @@
+--- cinelerra-gg/cinelerra-5.1/configure.ac 2018-11-02 16:41:41.523009718 +0800
++++ cinelerra-gg-new/cinelerra-5.1/configure.ac 2018-11-02 16:42:45.643716648 +0800
+@@ -669,8 +669,8 @@
EXRIStream() : Imf::IStream("mypath") {} };
class EXROStream : public Imf::OStream { public:
EXROStream() : Imf::OStream("mypath") {} };
@@ -20,8 +11,8 @@ diff -ruN cinelerra-gg/cinelerra-5.1/configure.ac cinelerra-gg-new/cinelerra-5.1
+ RESULT="$HAVE_openexr"
if test "x$RESULT" = "xyes"; then
SHARED_openexr="$LIBS"
- CFG_CFLAGS+=" -I/usr/include/OpenEXR"
-@@ -658,9 +658,9 @@
+ CFG_CFLAGS+=" -I/usr/include/OpenEXR -I/usr/local/include/OpenEXR"
+@@ -678,9 +678,9 @@
LIBS="$saved_LIBS"
CXXFLAGS="$saved_CXXFLAGS"
AC_LANG_POP(C++)
@@ -33,7 +24,7 @@ diff -ruN cinelerra-gg/cinelerra-5.1/configure.ac cinelerra-gg-new/cinelerra-5.1
# build global_config
OBJDIR=`uname -m`
-@@ -704,7 +704,7 @@
+@@ -724,7 +724,7 @@
libtheora/libogg libtheora/libvorbis ; do
lib=`dirname $dep`; needs=`basename $dep`
eval pkg_lib="\$PKG_$lib"; eval needs_lib="\$HAVE_$needs";
@@ -42,15 +33,3 @@ diff -ruN cinelerra-gg/cinelerra-5.1/configure.ac cinelerra-gg-new/cinelerra-5.1
eval "PKG_$needs=yes"
fi
done
-diff -ruN cinelerra-gg/cinelerra-5.1/thirdparty/Makefile cinelerra-gg-new/cinelerra-5.1/thirdparty/Makefile
---- cinelerra-gg/cinelerra-5.1/thirdparty/Makefile 2018-06-28 16:38:55.658446000 +0800
-+++ cinelerra-gg-new/cinelerra-5.1/thirdparty/Makefile 2018-06-28 16:39:14.942212329 +0800
-@@ -141,7 +141,7 @@
- $(call inc_path,fdk,libSYS) \
- $(call inc_path,fdk,libSYS/include)" \
- --extra-cxxflags="-D__STDC_CONSTANT_MACROS" \
-- --pkg-config=true \
-+ --pkg-config=/usr/bin/pkg-config \
- --extra-libs="-Wl,--start-group \
- $(call ld_path,twolame,libtwolame/.libs) \
- $(call ld_path,lame,libmp3lame/.libs) \