summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-11-18 16:41:54 +0800
committerUniversebenzene2021-11-18 16:41:54 +0800
commit633f62d61f7645d047ffd6851f10d9bb3b62a4e1 (patch)
tree2127fb02ea01ad0c350e360e631d02b5cebbae37
parent88d06fae239f5d6aa8302f334ea4250ec54fd026 (diff)
downloadaur-633f62d61f7645d047ffd6851f10d9bb3b62a4e1.tar.gz
Update to version 1.7.1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
2 files changed, 13 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e1fd6a64ca7..a33e69de1417 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = python-galpy
pkgdesc = Galactic Dynamics in python
- pkgver = 1.7.0
+ pkgver = 1.7.1
pkgrel = 1
url = http://galpy.readthedocs.io
arch = i686
arch = x86_64
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
makedepends = gsl
- source = https://files.pythonhosted.org/packages/source/g/galpy/galpy-1.7.0.tar.gz
- md5sums = e57fa62ff8cd6356e522d06eae9aafd9
+ source = https://files.pythonhosted.org/packages/source/g/galpy/galpy-1.7.1.tar.gz
+ md5sums = e6d96f823fd19180c88fc782e9b68cd9
pkgname = python-galpy
depends = python-scipy
@@ -18,22 +17,11 @@ pkgname = python-galpy
depends = python-future
depends = python-six
depends = python-pytest
+ depends = python-setuptools
optdepends = python-galpy-doc: Documentation for galpy
optdepends = gsl>=1.14: For some advanced features
optdepends = python-astropy: For Quantity support
optdepends = python-astroquery: For the Orbit.from_name initialization method
optdepends = python-numexpr: For or plotting arbitrary expressions of Orbit quantities
+ optdepends = python-jax: For use of constant-anisotropy DFs in galpy.df.constantbetadf
optdepends = python-pynbody-git: Foruse of SnapshotRZPotential and InterpSnapshotRZPotential
-
-pkgname = python2-galpy
- depends = python2-scipy
- depends = python2-matplotlib
- depends = python2-future
- depends = python2-six
- depends = python2-pytest
- optdepends = python-galpy-doc: Documentation for galpy
- optdepends = gsl>=1.14: For some advanced features
- optdepends = python2-astropy: For Quantity support
- optdepends = python2-astroquery: For the Orbit.from_name initialization method
- optdepends = python2-numexpr: For or plotting arbitrary expressions of Orbit quantities
- optdepends = python2-pynbody-git: Foruse of SnapshotRZPotential and InterpSnapshotRZPotential
diff --git a/PKGBUILD b/PKGBUILD
index 3598cbcd1c8d..921043f8f987 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,27 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-galpy
_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}" "python2-${_pyname}")
+pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=1.7.0
+pkgver=1.7.1
pkgrel=1
pkgdesc="Galactic Dynamics in python"
arch=('i686' 'x86_64')
url="http://galpy.readthedocs.io"
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools' 'gsl')
+makedepends=('python-setuptools' 'gsl')
#checkdepends=('python-pytest'
-## 'python2-pytest'
# 'python-matplotlib'
-## 'python2-matplotlib'
# 'python-future'
# 'python-scipy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('e57fa62ff8cd6356e522d06eae9aafd9')
+md5sums=('e6d96f823fd19180c88fc782e9b68cd9')
prepare() {
- cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
}
build() {
- msg "Building Python2"
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py build
-
- msg "Building Python3"
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py build
@@ -39,35 +31,19 @@ build() {
#check() {
# cd ${srcdir}/${_pyname}-${pkgver}
-## python setup.py test
-# pytest "build/lib.linux-${CARCH}-${_pyver}"
#
-## cd ${srcdir}/${_pyname}-${pkgver}-py2
-## python2 setup.py test
+## pytest "build/lib.linux-${CARCH}-${_pyver}"
+# python setup.py test
#}
-package_python2-galpy() {
- depends=('python2-scipy' 'python2-matplotlib' 'python2-future' 'python2-six' 'python2-pytest')
- optdepends=('python-galpy-doc: Documentation for galpy'
- 'gsl>=1.14: For some advanced features'
- 'python2-astropy: For Quantity support'
- 'python2-astroquery: For the Orbit.from_name initialization method'
- 'python2-numexpr: For or plotting arbitrary expressions of Orbit quantities'
- 'python2-pynbody-git: Foruse of SnapshotRZPotential and InterpSnapshotRZPotential')
- cd ${srcdir}/${_pyname}-${pkgver}-py2
-
- install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D -m644 README* -t "${pkgdir}/usr/share/doc/${pkgname}"
- python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
-}
-
package_python-galpy() {
- depends=('python-scipy' 'python-matplotlib' 'python-future' 'python-six' 'python-pytest')
+ depends=('python-scipy' 'python-matplotlib' 'python-future' 'python-six' 'python-pytest' 'python-setuptools')
optdepends=('python-galpy-doc: Documentation for galpy'
'gsl>=1.14: For some advanced features'
'python-astropy: For Quantity support'
'python-astroquery: For the Orbit.from_name initialization method'
'python-numexpr: For or plotting arbitrary expressions of Orbit quantities'
+ 'python-jax: For use of constant-anisotropy DFs in galpy.df.constantbetadf'
'python-pynbody-git: Foruse of SnapshotRZPotential and InterpSnapshotRZPotential')
cd ${srcdir}/${_pyname}-${pkgver}