summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Derumigny2023-11-18 12:52:56 +0100
committerNicolas Derumigny2023-11-18 12:52:56 +0100
commit6367f64b02d1da293bbb81e0f0c0e4b60e6f3de3 (patch)
tree7b3a3c84b2abd876698c93dfa39ae493c6e2cb2e
parent48f8d4f3be9af2e96e0dba6afbc1b416e55c9998 (diff)
downloadaur-6367f64b02d1da293bbb81e0f0c0e4b60e6f3de3.tar.gz
v21.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--spack.env.sh.patch20
3 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8229569e0451..9e830cc889cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spack
pkgdesc = A flexible package manager for supercomputer that supports multiple versions, configurations, platforms, and compilers.
- pkgver = 0.20.1
+ pkgver = 0.21.0
pkgrel = 1
url = https://spack.io/
arch = i686
@@ -10,7 +10,7 @@ pkgbase = spack
depends = polkit
optdepends = env-modules-tcl
optdepends = lmod
- source = spack-0.20.1.tar.gz::https://github.com/spack/spack/archive/v0.20.1.tar.gz
+ source = spack-0.21.0.tar.gz::https://github.com/spack/spack/archive/v0.21.0.tar.gz
source = spack.sysusers
source = spack.tmpfiles
source = spack.pkaction
@@ -19,7 +19,7 @@ pkgbase = spack
source = spack.csh
source = spack.bin.py
source = spack.env.sh.patch
- sha256sums = 141be037b56e4b095840a95ac51c428c29dad078f7f88140ae6355b2a1b32dc3
+ sha256sums = SKIP
sha256sums = e6d46e8f5140b4e86596d38f23af379d9adce8e9afc66f800571d7a4d9211e19
sha256sums = db0cc4a4ab32e6ee2e5c32898c69a0f0ce05b4e3c605beb024b5463c46e3710f
sha256sums = 1f2c4c6b8841d927fa4056206b8e5603719c0d829586ff0937efaa935d054376
@@ -27,6 +27,6 @@ pkgbase = spack
sha256sums = 0bddb0a0f1d470509f44c3031041ab0de5472de84f58c90d4b6c91e6782cb6a2
sha256sums = 7b427625d7890dbc0ae493da095a4d7de47742fd3b02e3f42d7ee52e3599a4ac
sha256sums = 70ac76748d40d93fb5e5597fbaae933756c4eeb0b8969255e16435d0fad60006
- sha256sums = 3249ca591216ca118f5a778dc9c0ba27d2f66e1a685fa101511a06bfa09a0d13
+ sha256sums = bcde5253c94d2117fec9cc96f52924c99588b06a052782c22a1f3bc6da3043e8
pkgname = spack
diff --git a/PKGBUILD b/PKGBUILD
index 3d0a0f383232..fe280c8d2609 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Nicolas Derumigny nderumigny <at> gmail <dot> com
pkgname=spack
-pkgver=0.20.1
+pkgver=0.21.0
pkgrel=1
pkgdesc="A flexible package manager for supercomputer that supports multiple versions, configurations, platforms, and compilers."
arch=('i686' 'x86_64')
@@ -20,7 +20,7 @@ source=(
spack.env.sh.patch
)
sha256sums=(
- '141be037b56e4b095840a95ac51c428c29dad078f7f88140ae6355b2a1b32dc3'
+ 'SKIP'
'e6d46e8f5140b4e86596d38f23af379d9adce8e9afc66f800571d7a4d9211e19'
'db0cc4a4ab32e6ee2e5c32898c69a0f0ce05b4e3c605beb024b5463c46e3710f'
'1f2c4c6b8841d927fa4056206b8e5603719c0d829586ff0937efaa935d054376'
@@ -28,7 +28,7 @@ sha256sums=(
'0bddb0a0f1d470509f44c3031041ab0de5472de84f58c90d4b6c91e6782cb6a2'
'7b427625d7890dbc0ae493da095a4d7de47742fd3b02e3f42d7ee52e3599a4ac'
'70ac76748d40d93fb5e5597fbaae933756c4eeb0b8969255e16435d0fad60006'
- '3249ca591216ca118f5a778dc9c0ba27d2f66e1a685fa101511a06bfa09a0d13'
+ 'bcde5253c94d2117fec9cc96f52924c99588b06a052782c22a1f3bc6da3043e8'
)
_spackroot=/opt/spack
_spackcfg=etc/spack/defaults/config.yaml
diff --git a/spack.env.sh.patch b/spack.env.sh.patch
index 405257d54140..750d5508f05f 100644
--- a/spack.env.sh.patch
+++ b/spack.env.sh.patch
@@ -38,7 +38,7 @@
else
case $_sp_arg in
activate)
-@@ -133,10 +137,10 @@
+@@ -132,10 +136,10 @@
[ "${_a#* --help}" != "$_a" ];
then
# No args or args contain --sh, --csh, or -h/--help: just execute.
@@ -46,12 +46,12 @@
+ _pkexec_env env activate "$@"
else
# Actual call to activate: source the output.
-- stdout="$(command spack $_sp_flags env activate --sh "$@")" || return
-+ stdout="$(_pkexec_env $_sp_flags env activate --sh "$@")" || return
+- stdout="$(SPACK_COLOR="${SPACK_COLOR:-always}" command spack $_sp_flags env activate --sh "$@")" || return
++ stdout="$(SPACK_COLOR="${SPACK_COLOR:-always}" _pkexec_env $_sp_flags env activate --sh "$@")" || return
eval "$stdout"
fi
;;
-@@ -152,18 +156,18 @@
+@@ -151,18 +155,18 @@
[ "${_a#* --csh}" != "$_a" ];
then
# Args contain --sh or --csh: just execute.
@@ -63,8 +63,8 @@
+ _pkexec_env env deactivate -h
else
# No args: source the output of the command.
-- stdout="$(command spack $_sp_flags env deactivate --sh)" || return
-+ stdout="$(_pkexec_env $_sp_flags env deactivate --sh)" || return
+- stdout="$(SPACK_COLOR="${SPACK_COLOR:-always}" command spack $_sp_flags env deactivate --sh)" || return
++ stdout="$(SPACK_COLOR="${SPACK_COLOR:-always}" _pkexec_env $_sp_flags env deactivate --sh)" || return
eval "$stdout"
fi
;;
@@ -74,15 +74,15 @@
;;
esac
fi
-@@ -184,14 +188,14 @@
+@@ -183,14 +187,14 @@
[ "${_a#* --help}" != "$_a" ];
then
# Args contain --sh, --csh, or -h/--help: just execute.
- command spack $_sp_flags $_sp_subcommand "$@"
+ _pkexec_env $_sp_flags $_sp_subcommand "$@"
else
-- stdout="$(command spack $_sp_flags $_sp_subcommand --sh "$@")" || return
-+ stdout="$(_pkexec_env $_sp_flags $_sp_subcommand --sh "$@")" || return
+- stdout="$(SPACK_COLOR="${SPACK_COLOR:-always}" command spack $_sp_flags $_sp_subcommand --sh "$@")" || return
++ stdout="$(SPACK_COLOR="${SPACK_COLOR:-always}" _pkexec_env $_sp_flags $_sp_subcommand --sh "$@")" || return
eval "$stdout"
fi
;;
@@ -92,7 +92,7 @@
;;
esac
}
-@@ -366,7 +370,7 @@
+@@ -365,7 +369,7 @@
_spack_pathadd PATH "${_sp_module_bin}"
fi;
else