summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrxx2019-07-05 16:46:25 +0200
committermrxx2019-07-05 16:46:25 +0200
commit637ed70c44634affb84e2e1978baa7c47f089394 (patch)
treebe7552d4feefedb41d44ae00faeba96b4f220eaf
parent1a8b784859960ce32fd6d59e1339dc0d9db4fba8 (diff)
downloadaur-637ed70c44634affb84e2e1978baa7c47f089394.tar.gz
Add missing linker library
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 947013ff7b75..9678d50d55a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ethminer
pkgdesc = Ethereum miner with OpenCL and stratum support (built without CUDA).
pkgver = 0.17.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ethereum-mining/ethminer
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 0c7e9bc5eaa6..1e7c70a9e604 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=ethminer
pkgver=0.17.1
-pkgrel=1
+pkgrel=2
pkgdesc="Ethereum miner with OpenCL and stratum support (built without CUDA)."
arch=('x86_64')
url="https://github.com/ethereum-mining/ethminer"
@@ -18,6 +18,10 @@ sha256sums=('SKIP')
build () {
cd "$pkgname"
git submodule update --init --recursive
+
+ # add missing library for linking
+ sed -i 's/CLI11 Boost::system)/CLI11 Boost::system Boost::filesystem)/' ethminer/CMakeLists.txt
+
mkdir -p build && cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DETHASHCUDA=OFF