summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorckath2019-08-31 21:02:13 +0200
committerckath2019-08-31 21:02:13 +0200
commit63810e395b3bb0b2f727f8be047c89162b937335 (patch)
tree2e5f6e3795da0db4e0efdc9e746d939c008c3775
parent9d20fe51bc22ddaf20c0b92a0dc0ac5db66dfb62 (diff)
downloadaur-63810e395b3bb0b2f727f8be047c89162b937335.tar.gz
compile from release tar, add md5sum
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfa3db2d3813..69650d0214e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,8 +10,8 @@ pkgbase = fuf
optdepends = w3m: image previews
provides = fuf
conflicts = fuf-git
- source = fuf::git+https://github.com/ckath/fuf.git#tag=v0.1
- md5sums = SKIP
+ source = fuf::https://github.com/Ckath/fuf/archive/v0.1.tar.gz
+ md5sums = b71cc7ddbe66bc675a4e5738edfc410a
pkgname = fuf
diff --git a/PKGBUILD b/PKGBUILD
index 907229cc2ffb..b699b566431a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,16 +11,16 @@ optdepends=('w3m: image previews')
conflicts=('fuf-git')
provides=('fuf')
install=fuf.install
-source=("$pkgname::git+https://github.com/ckath/fuf.git#tag=v$pkgver")
-md5sums=('SKIP')
+source=("$pkgname::https://github.com/Ckath/fuf/archive/v$pkgver.tar.gz")
+md5sums=('b71cc7ddbe66bc675a4e5738edfc410a')
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
make
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
install -Dm755 fuf "$pkgdir/usr/bin/fuf"
install -Dm755 scripts/open "$pkgdir/usr/lib/$pkgname/open"
install -Dm755 scripts/preview "$pkgdir/usr/lib/$pkgname/preview"