summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2019-09-12 07:30:27 +0300
committerYurii Kolesnykov2019-09-12 07:30:27 +0300
commit63a73e78a96041dcf132912432b67e9e829ba1be (patch)
treea09da2e8cfb6dcd3799de46b820f5f2d7b3dbf7f
parentd73eaa5c59fabfefdab71d4df6a930c5b1a646eb (diff)
downloadaur-63a73e78a96041dcf132912432b67e9e829ba1be.tar.gz
5.4.857604.9c9284f9cee9
-rw-r--r--.SRCINFO7
-rw-r--r--90-linux.hook9
-rw-r--r--PKGBUILD33
-rw-r--r--linux.preset33
4 files changed, 37 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01930fd97546..64f016c5ad32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,10 @@ pkgbase = linux-amd-git
makedepends = libelf
makedepends = git
makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
makedepends = graphviz
+ makedepends = imagemagick
+ makedepends = git
options = !strip
source = linux-amd-git::git://people.freedesktop.org/~agd5f/linux#branch=drm-next-5.4
source = config
@@ -22,8 +25,8 @@ pkgbase = linux-amd-git
sha256sums = SKIP
sha256sums = cf89e945f03bc0863904c2daf68f476f726d1a596a087a9bc217580bfe7423ee
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
- sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
- sha256sums = 997dd1ca5c59e526a35d8367e6371a68406b1a58b90006e6f85d59a580c7503f
+ sha256sums = 834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0
+ sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
pkgname = linux-amd-git
pkgdesc = The Linux-amd-git kernel and modules
diff --git a/90-linux.hook b/90-linux.hook
index b33873c854fb..9851151995bc 100644
--- a/90-linux.hook
+++ b/90-linux.hook
@@ -2,11 +2,10 @@
Type = File
Operation = Install
Operation = Upgrade
-Operation = Remove
-Target = usr/lib/modules/%KERNVER%/*
-Target = usr/lib/modules/%EXTRAMODULES%/*
+Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/initcpio/*
[Action]
-Description = Updating %PKGBASE% module dependencies...
+Description = Updating %PKGBASE% initcpios
When = PostTransaction
-Exec = /usr/bin/depmod %KERNVER%
+Exec = /usr/bin/mkinitcpio -p %PKGBASE%
diff --git a/PKGBUILD b/PKGBUILD
index cea070d5ca95..c098d33b0c2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,10 @@ pkgrel=1
arch=(x86_64)
url='https://cgit.freedesktop.org/~agd5f/linux/'
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf git python-sphinx graphviz)
+makedepends=(
+ xmlto kmod inetutils bc libelf git python-sphinx python-sphinx_rtd_theme
+ graphviz imagemagick git
+)
options=('!strip')
source=("${pkgbase}::git://people.freedesktop.org/~agd5f/linux#branch=${_branch}"
config # the main kernel config file
@@ -28,8 +31,8 @@ source=("${pkgbase}::git://people.freedesktop.org/~agd5f/linux#branch=${_branch}
sha256sums=('SKIP'
'cf89e945f03bc0863904c2daf68f476f726d1a596a087a9bc217580bfe7423ee'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- 'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '997dd1ca5c59e526a35d8367e6371a68406b1a58b90006e6f85d59a580c7503f')
+ '834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0'
+ 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
pkgver() {
cd "${_srcname}"
local version="$(grep \^VERSION Makefile|cut -d"=" -f2|cut -d" " -f2)"
@@ -69,7 +72,7 @@ prepare() {
build() {
cd $_srcname
- make bzImage modules #htmldocs
+ make bzImage modules htmldocs
}
_package() {
@@ -220,17 +223,17 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- # msg2 "Removing doctrees..."
- # rm -r "$builddir/Documentation/output/.doctrees"
-
- # msg2 "Moving HTML docs..."
- # local src dst
- # while read -rd '' src; do
- # dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- # mkdir -p "${dst%/*}"
- # mv "$src" "$dst"
- # rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- # done < <(find "$builddir/Documentation/output" -type f -print0)
+ msg2 "Removing doctrees..."
+ rm -r "$builddir/Documentation/output/.doctrees"
+
+ msg2 "Moving HTML docs..."
+ local src dst
+ while read -rd '' src; do
+ dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
+ mkdir -p "${dst%/*}"
+ mv "$src" "$dst"
+ rmdir -p --ignore-fail-on-non-empty "${src%/*}"
+ done < <(find "$builddir/Documentation/output" -type f -print0)
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
diff --git a/linux.preset b/linux.preset
index 046277584140..66709a8c1537 100644
--- a/linux.preset
+++ b/linux.preset
@@ -1,27 +1,14 @@
-post_install () {
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod %KERNVER%
-}
+# mkinitcpio preset file for the '%PKGBASE%' package
-post_upgrade() {
- if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
- echo "WARNING: /boot appears to be a separate partition but is not mounted."
- fi
+ALL_config="/etc/mkinitcpio.conf"
+ALL_kver="/boot/vmlinuz-%PKGBASE%"
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod %KERNVER%
+PRESETS=('default' 'fallback')
- if [ $(vercmp $2 3.13) -lt 0 ]; then
- echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
- echo ">>> In order to use your keyboard during early init, you MUST"
- echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
- fi
-}
+#default_config="/etc/mkinitcpio.conf"
+default_image="/boot/initramfs-%PKGBASE%.img"
+#default_options=""
-post_remove() {
- # also remove the compat symlinks
- rm -f boot/initramfs-%PKGBASE%.img
- rm -f boot/initramfs-%PKGBASE%-fallback.img
-}
+#fallback_config="/etc/mkinitcpio.conf"
+fallback_image="/boot/initramfs-%PKGBASE%-fallback.img"
+fallback_options="-S autodetect"