summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2021-06-30 20:00:26 +0200
committerHans-Nikolai Viessmann2021-06-30 20:00:26 +0200
commit63c5f1d46444041f5afc5f0b94f9812c1ddbc768 (patch)
tree8b35f0476d0412f5c455dfb2832b1fccd299f640
parent5ec68efb26af91a9d581d5d3aa0d5c75ba7842ca (diff)
downloadaur-63c5f1d46444041f5afc5f0b94f9812c1ddbc768.tar.gz
update git URL to gitlab.archlinux.org
this unfortunately changes the version number, as the tags from the old git.archlinux.org repo where not migrated...
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1b7af573691..3c41fe1220cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tllocalmgr-git
pkgdesc = A shell and command-line utility to manage TeXLive on Arch Linux
- pkgver = v0.7.r3.gbbd8488
- pkgrel = 7
+ pkgver = r84.bbd8488
+ pkgrel = 1
url = https://git.archlinux.org/users/remy/texlive-localmanager.git/
arch = any
license = GPL
@@ -13,10 +13,12 @@ pkgbase = tllocalmgr-git
depends = perl-term-readline-gnu
depends = perl-list-moreutils
depends = perl-lwp-protocol-https
+ provides = texlive-localmanager=r84.bbd8488
provides = texlive-localmanager=v0.7.r3.gbbd8488
+ provides = tllocalmgr-git=v0.7.r3.gbbd8488
conflicts = texlive-localmanager
conflicts = texlive-localmanager-git
- source = texlive-localmanager::git+http://git.archlinux.org/users/remy/texlive-localmanager.git
+ source = texlive-localmanager::git+https://gitlab.archlinux.org/remy/texlive-localmanager.git
source = tllocalmgr-2021.patch
source = tllocalmgr-enhance.patch
source = tllocalmgr-fix-texlive-local-match.patch
@@ -28,4 +30,3 @@ pkgbase = tllocalmgr-git
sha256sums = 1538426adada826f8faeed826e9be5f5610ade23ce0437535e39662294e6e108
pkgname = tllocalmgr-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6196fa600415..d1859dc8b81d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@
pkgname=tllocalmgr-git
_pkgname='texlive-localmanager'
-pkgver=v0.7.r3.gbbd8488
-pkgrel=7
+pkgver=r84.bbd8488
+pkgrel=1
pkgdesc='A shell and command-line utility to manage TeXLive on Arch Linux'
arch=('any')
url='https://git.archlinux.org/users/remy/texlive-localmanager.git/'
license=('GPL')
-provides=("texlive-localmanager=$pkgver")
+provides=("texlive-localmanager=$pkgver" "texlive-localmanager=v0.7.r3.gbbd8488" "$pkgname=v0.7.r3.gbbd8488")
conflicts=('texlive-localmanager'
'texlive-localmanager-git')
depends=('texlive-core>=2016'
@@ -24,7 +24,7 @@ depends=('texlive-core>=2016'
'perl-lwp-protocol-https')
makedepends=('git')
-source=("${_pkgname}::git+http://git.archlinux.org/users/remy/texlive-localmanager.git"
+source=("${_pkgname}::git+https://gitlab.archlinux.org/remy/texlive-localmanager.git"
'tllocalmgr-2021.patch'
'tllocalmgr-enhance.patch'
'tllocalmgr-fix-texlive-local-match.patch'
@@ -37,7 +37,10 @@ sha256sums=('SKIP'
pkgver() {
cd "$_pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
prepare() {