summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAudun-Marius Gangstø2022-02-07 15:08:41 +0800
committerAudun-Marius Gangstø2022-02-07 15:09:48 +0800
commit63cae6ecc5ebcbb38d85021e6c2dfd2b4e758dc1 (patch)
tree6e1bc00dc00fdc26bccba796777461d603f36619
downloadaur-63cae6ecc5ebcbb38d85021e6c2dfd2b4e758dc1.tar.gz
The current version is 8.0.0 (19.10.2020 15:00 UTC).
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD57
-rw-r--r--response.varfile12
-rw-r--r--snap-conf-optimiser.desktop8
-rw-r--r--snap-desktop.desktop7
5 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..140bfabaccbc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = esa-snap-bin
+ pkgdesc = ESA SNAP Toolbox for Sentinel Satellite data
+ pkgver = 8.0.0
+ pkgrel = 1
+ url = http://step.esa.int/main/
+ arch = x86_64
+ license = GPL3
+ depends = jre8-openjdk
+ provides = esa-snap
+ noextract = esa-snap_all_unix_8_0.sh
+ options = !strip
+ source = https://download.esa.int/step/snap/8.0/installers/esa-snap_all_unix_8_0.sh
+ source = snap-conf-optimiser.desktop
+ source = snap-desktop.desktop
+ source = response.varfile
+ md5sums = 9e5fbb15d6a0b247139d47bf7072437d
+ md5sums = cc4814b417fba1c6ce2782654b18d8b8
+ md5sums = b30e02a81cce3370eb9e04ce4caee040
+ md5sums = 171e808a3ba22fb6a522aa318a8703db
+ sha256sums = b49d6795f55bbe9ecb46f9c289ac245626243d3fcd32211b47a54b26b508798e
+ sha256sums = bc705ce50143ee597485f1dbbef0e62794c62af781c4af71db2f304b34c7ee01
+ sha256sums = 8d07671f6e94250ac333a34f1c8288f09e89428cbe9bf9c2af4a5226182cc2f9
+ sha256sums = 97f680aec00cc74ec2f202aba1e0132c461d631d705203ab613371c9c4c28f2d
+
+pkgname = esa-snap-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be4cf00046c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Audun-Marius Gangstø <audun@gangsto.org>
+pkgname=esa-snap-bin
+pkgver=8.0.0
+pkgrel=1
+pkgdesc="ESA SNAP Toolbox for Sentinel Satellite data"
+arch=("x86_64")
+url="http://step.esa.int/main/"
+license=('GPL3')
+options=("!strip")
+provides=("esa-snap")
+depends=("jre8-openjdk")
+source=("https://download.esa.int/step/snap/${pkgver:0:3}/installers/${pkgname/-bin/}_all_unix_${pkgver:0:1}_${pkgver:2:1}.sh"
+ "snap-conf-optimiser.desktop"
+ "snap-desktop.desktop"
+ "response.varfile"
+ )
+noextract=("${pkgname/-bin/}_all_unix_${pkgver:0:1}_${pkgver:2:1}.sh")
+md5sums=("9e5fbb15d6a0b247139d47bf7072437d"
+ "cc4814b417fba1c6ce2782654b18d8b8"
+ "b30e02a81cce3370eb9e04ce4caee040"
+ "171e808a3ba22fb6a522aa318a8703db"
+)
+sha256sums=("b49d6795f55bbe9ecb46f9c289ac245626243d3fcd32211b47a54b26b508798e"
+ "bc705ce50143ee597485f1dbbef0e62794c62af781c4af71db2f304b34c7ee01"
+ "8d07671f6e94250ac333a34f1c8288f09e89428cbe9bf9c2af4a5226182cc2f9"
+ "97f680aec00cc74ec2f202aba1e0132c461d631d705203ab613371c9c4c28f2d"
+)
+
+
+package() {
+ cd "$srcdir"
+ install -d "${pkgdir}/opt/"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/icons"
+ install -d "${pkgdir}/usr/share/applications"
+
+ # java.util.prefs.userRoot is set to silence some warnings during install. We have to delete it afterwards
+ sh esa-snap_all_unix_8_0.sh -q -dir "${pkgdir}/opt/snap" -J-Djava.util.prefs.userRoot="${pkgdir}/" -Vsys.symlinkDir=${pkgdir}/usr/bin
+
+
+ install -Dm 644 "${srcdir}"/snap-desktop.desktop "${pkgdir}"/usr/share/applications
+ install -Dm 644 "${srcdir}"/snap-conf-optimiser.desktop "${pkgdir}"/usr/share/applications
+
+ cp "${pkgdir}"/opt/snap/.install4j/i4j_extf_5_1buu1c8.jpg "${pkgdir}"/usr/share/icons/esa-snap-desktop.jpg
+ # This icon file is somehow truncated.
+ cp "${pkgdir}"/opt/snap/.install4j/i4j_extf_3_1buu1c8.jpg "${pkgdir}"/opt/snap/bin/SNAP_icon_48.jpg
+ cp "${pkgdir}"/opt/snap/.install4j/snap-conf-optimiser.png "${pkgdir}"/usr/share/icons/snap-conf-optimiser.png
+ # Set -Xmx to two thirds of system memory. Seems to be what the installer does.
+ maxmem="$(awk '/MemTotal/{print int(($2/1024^2) * .7)}' /proc/meminfo)"
+ sed "s/-Xmx[^ ]*/-Xmx${maxmem}G/;s#^jdkhome.*#jdkhome=\"/usr/lib/jvm/java-8-openjdk/jre/\"#" -i "${pkgdir}"/opt/snap/etc/snap.conf
+
+
+ # Deleting java user root and uninstaller, both related to the uninstaller.
+ # Also removing the accompanying jre.
+ rm -rf "${pkgdir}"/.java "${pkgdir}"/opt/snap/.install4j "${pkgdir}"/opt/snap/jre
+
+}
diff --git a/response.varfile b/response.varfile
new file mode 100644
index 000000000000..7d751937ae69
--- /dev/null
+++ b/response.varfile
@@ -0,0 +1,12 @@
+# install4j response file for ESA SNAP 8.0
+deleteSnapDir=DESKTOP
+executeLauncherAction$Boolean=true
+forcePython$Boolean=false
+sys.adminRights$Boolean=true
+sys.component.RSTB$Boolean=true
+sys.component.S1TBX$Boolean=true
+sys.component.S2TBX$Boolean=true
+sys.component.S3TBX$Boolean=true
+sys.component.SNAP$Boolean=true
+sys.languageId=en
+sys.programGroupDisabled$Boolean=false
diff --git a/snap-conf-optimiser.desktop b/snap-conf-optimiser.desktop
new file mode 100644
index 000000000000..48be8e9a627e
--- /dev/null
+++ b/snap-conf-optimiser.desktop
@@ -0,0 +1,8 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Type=Application
+Name=SNAP Configuration Optimiser
+Exec="/opt/snap/bin/snap-conf-optimiser" %U
+Icon=snap-conf-optimiser
+Categories=Education;Science;Geography;
+StartupWMClass=install4j-org-esa-snap-smart-configurator-ui-SmartConfigurator
diff --git a/snap-desktop.desktop b/snap-desktop.desktop
new file mode 100644
index 000000000000..ae2ddaacabb8
--- /dev/null
+++ b/snap-desktop.desktop
@@ -0,0 +1,7 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Type=Application
+Name=SNAP Desktop
+Exec=/bin/sh "/opt/snap/bin/snap" %U
+Categories=Education;Science;Geography;
+Icon=esa-snap-desktop