summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2023-01-30 22:07:53 +0800
committertaotieren2023-01-30 22:07:53 +0800
commit63d8bd6b6e6fdb00c37436c172f9837e720f091e (patch)
tree4c43652820b8677d41403b0a1fdbb471887621d8
downloadaur-63d8bd6b6e6fdb00c37436c172f9837e720f091e.tar.gz
Add python-glyphslib-git
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD56
2 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ec2cf8ffc04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = python-glyphslib-git
+ pkgdesc = A bridge from Glyphs source files (.glyphs) to UFOs
+ pkgver = 6.1.0.r57.g416dcbf6
+ pkgrel = 1
+ url = https://github.com/googlefonts/glyphsLib
+ arch = any
+ license = Apache-2.0
+ checkdepends = python-lxml
+ checkdepends = python-pytest
+ checkdepends = python-ufo2ft
+ checkdepends = python-ufonormalizer
+ checkdepends = python-xmldiff
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-defcon
+ makedepends = python-setuptools-scm
+ makedepends = git
+ depends = python
+ depends = python-fonttools
+ depends = python-fs
+ depends = python-openstep-plist
+ depends = python-ufolib2
+ depends = python-unicodedata2
+ optdepends = python-defcon
+ optdepends = python-ufonormalizer
+ provides = python-glyphslib
+ conflicts = python-glyphslib
+ source = python-glyphslib-git::git+https://github.com/googlefonts/glyphsLib.git
+ sha256sums = SKIP
+
+pkgname = python-glyphslib-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1172949e050
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=python-glyphslib-git
+pkgver=6.1.0.r57.g416dcbf6
+pkgrel=1
+pkgdesc='A bridge from Glyphs source files (.glyphs) to UFOs'
+url='https://github.com/googlefonts/glyphsLib'
+license=('Apache-2.0')
+arch=(any)
+_pydeps=(fonttools
+ fs # for fonttools[ufo]
+ openstep-plist
+ ufolib2
+ unicodedata2) # for fonttools[unicode]
+depends=(python
+ "${_pydeps[@]/#/python-}")
+makedepends=(python-{build,installer,wheel}
+ python-defcon
+ python-setuptools-scm
+ git)
+_pycheckdeps=(lxml # for fonttools[lxml]
+ pytest
+ ufo2ft
+ ufonormalizer
+ xmldiff)
+checkdepends=("${_pycheckdeps[@]/#/python-}")
+optdepends=(python-defcon
+ python-ufonormalizer)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//g;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ python -m build -wn
+}
+
+check() {
+ cd "$pkgname"
+ PYTHONPATH=Lib pytest tests \
+ --deselect tests/builder/interpolation_test.py \
+ --deselect tests/builder/designspace_gen_test.py \
+ --deselect tests/builder/builder_test.py
+}
+
+package() {
+ cd "$pkgname"
+ python -m installer -d "$pkgdir" dist/*.whl
+}
+