summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThibault2015-07-06 10:48:49 +0200
committerThibault2015-07-06 10:48:49 +0200
commit63e968ac88f677ca90db02f8280f5857320dbb99 (patch)
tree3ef18df3e3afa398b51f15835a3566baf7153075
downloadaur-63e968ac88f677ca90db02f8280f5857320dbb99.tar.gz
AUR4 initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD45
-rw-r--r--crack-attack-1.1.14-audio-ppc.patch12
-rw-r--r--crack-attack-1.1.14-audio.patch37
-rw-r--r--crack-attack-1.1.14-gcc43.patch11
-rw-r--r--crack-attack-1.1.14-glutInit.patch11
6 files changed, 143 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d84ea9544b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = crack-attack
+ pkgdesc = A free OpenGL game based on the Super Nintendo classic Tetris Attack, with Fedora's patches
+ pkgver = 1.1.14
+ pkgrel = 7
+ url = http://www.nongnu.org/crack-attack/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = glu
+ makedepends = libxmu
+ depends = gtk2
+ depends = sdl_mixer
+ depends = freeglut
+ optdepends = crack-attack-sounds: for sound effects and music
+ source = http://download.savannah.gnu.org/releases/crack-attack/crack-attack-1.1.14.tar.gz
+ source = crack-attack-1.1.14-glutInit.patch
+ source = crack-attack-1.1.14-audio.patch
+ source = crack-attack-1.1.14-gcc43.patch
+ source = crack-attack-1.1.14-audio-ppc.patch
+ md5sums = 262445024b0fca44508355242ea29d71
+ md5sums = 75a884a0003521099b4bb417bfe8339b
+ md5sums = 6c42bef707937b3bede26dc83e865e74
+ md5sums = b6a21f65d3579a6cf3c9e48cede0b012
+ md5sums = 1d24a261ea6b3a2d15328c3b7d9305d0
+
+pkgname = crack-attack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..056373b20bfb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Thibault Mondary <thibm@free.fr>
+# Maintainer: Simone Sclavi 'Ito' <darkhado@gmail.com>
+
+
+pkgname=crack-attack
+pkgver=1.1.14
+pkgrel=7
+pkgdesc="A free OpenGL game based on the Super Nintendo classic Tetris Attack, with Fedora's patches"
+arch=('i686' 'x86_64')
+url="http://www.nongnu.org/crack-attack/"
+license=("GPL")
+depends=('gtk2' 'sdl_mixer' 'freeglut')
+makedepends=('glu' 'libxmu')
+optdepends=('crack-attack-sounds: for sound effects and music')
+source=(http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+ crack-attack-1.1.14-glutInit.patch
+ crack-attack-1.1.14-audio.patch
+ crack-attack-1.1.14-gcc43.patch
+ crack-attack-1.1.14-audio-ppc.patch
+)
+md5sums=('262445024b0fca44508355242ea29d71'
+ '75a884a0003521099b4bb417bfe8339b'
+ '6c42bef707937b3bede26dc83e865e74'
+ 'b6a21f65d3579a6cf3c9e48cede0b012'
+ '1d24a261ea6b3a2d15328c3b7d9305d0')
+
+build() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i ../crack-attack-1.1.14-glutInit.patch
+ patch -Np1 -i ../crack-attack-1.1.14-audio.patch
+ patch -Np1 -i ../crack-attack-1.1.14-gcc43.patch
+ patch -Np1 -i ../crack-attack-1.1.14-audio-ppc.patch
+
+ ./configure --enable-sound=yes --prefix=/usr --mandir=/usr/share/man
+ make
+}
+package(){
+ cd $pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+
+ cd data
+ sed -i -e 's#Application;Games#Game;BlockGame#' crack-attack.desktop
+ install -D -m644 crack-attack.desktop $pkgdir/usr/share/applications/crack-attack.desktop
+ install -D -m644 crack-attack.xpm $pkgdir/usr/share/pixmaps/crack-attack.xpm
+}
diff --git a/crack-attack-1.1.14-audio-ppc.patch b/crack-attack-1.1.14-audio-ppc.patch
new file mode 100644
index 000000000000..92e716c47d51
--- /dev/null
+++ b/crack-attack-1.1.14-audio-ppc.patch
@@ -0,0 +1,12 @@
+diff -up crack-attack-1.1.14/src/Sound.cxx~ crack-attack-1.1.14/src/Sound.cxx
+--- crack-attack-1.1.14/src/Sound.cxx~ 2008-06-24 11:20:22.000000000 +0200
++++ crack-attack-1.1.14/src/Sound.cxx 2008-06-24 11:20:22.000000000 +0200
+@@ -41,7 +41,7 @@ ChunkMap chunks;
+ int audio_rate = 22050;
+ int audio_channels = 2;
+ int audio_buffers = 1024; /* small enough buffer to get synchronized sound */
+-Uint16 audio_format = AUDIO_S16; /* 16-bit stereo */
++Uint16 audio_format = AUDIO_S16SYS; /* 16-bit stereo */
+ int has_audio_available = 0;
+
+ void Sound::initialize( void )
diff --git a/crack-attack-1.1.14-audio.patch b/crack-attack-1.1.14-audio.patch
new file mode 100644
index 000000000000..a091aa4df7fa
--- /dev/null
+++ b/crack-attack-1.1.14-audio.patch
@@ -0,0 +1,37 @@
+--- crack-attack-1.1.14/src/Music.h~ 2007-01-12 10:54:25.000000000 +0100
++++ crack-attack-1.1.14/src/Music.h 2007-01-12 10:54:25.000000000 +0100
+@@ -34,10 +34,10 @@
+ #include <vector>
+
+ #define GC_MUSIC_FILENAME_LENGTH 128
+-#define GC_MUSIC_PRELUDE_TRACK "prelude"
+-#define GC_MUSIC_GAME_TRACK "game"
+-#define GC_MUSIC_GAMEOVER_TRACK "gameover"
+-#define GC_MUSIC_YOUWIN_TRACK "youwin"
++#define GC_MUSIC_PRELUDE_TRACK "prelude.xm"
++#define GC_MUSIC_GAME_TRACK "game.xm"
++#define GC_MUSIC_GAMEOVER_TRACK "gameover.xm"
++#define GC_MUSIC_YOUWIN_TRACK "youwin.xm"
+
+ class Music {
+ public:
+--- crack-attack-1.1.14/src/Music.cxx~ 2007-01-12 11:23:15.000000000 +0100
++++ crack-attack-1.1.14/src/Music.cxx 2007-01-12 11:23:15.000000000 +0100
+@@ -91,7 +91,7 @@
+ cout << "Playing " << music_filelist[current_track].c_str() << endl;
+ #endif
+ music = Mix_LoadMUS( music_filelist[current_track].c_str() );
+- Mix_VolumeMusic( MIX_MAX_VOLUME / 4 );
++ Mix_VolumeMusic( (MIX_MAX_VOLUME * 8) / 10 );
+ Mix_PlayMusic( music , 0 );
+ Mix_HookMusicFinished(Music::finished);
+ keep_playing = 1;
+@@ -126,7 +126,7 @@
+ cout << "Playing " << Track.c_str() << endl;
+ #endif
+ music = Mix_LoadMUS( Track.c_str() );
+- Mix_VolumeMusic( MIX_MAX_VOLUME / 4 );
++ Mix_VolumeMusic( (MIX_MAX_VOLUME * 8) / 10 );
+ Mix_PlayMusic( music , 0 );
+ keep_playing = 0;
+ }
diff --git a/crack-attack-1.1.14-gcc43.patch b/crack-attack-1.1.14-gcc43.patch
new file mode 100644
index 000000000000..3e05f6571364
--- /dev/null
+++ b/crack-attack-1.1.14-gcc43.patch
@@ -0,0 +1,11 @@
+diff -up crack-attack-1.1.14/src/TextureLoader.h~ crack-attack-1.1.14/src/TextureLoader.h
+--- crack-attack-1.1.14/src/TextureLoader.h~ 2008-01-04 23:07:02.000000000 +0100
++++ crack-attack-1.1.14/src/TextureLoader.h 2008-01-04 23:07:02.000000000 +0100
+@@ -28,6 +28,7 @@
+ #define TEXTURELOADER_H
+
+ #include <GL/glut.h>
++#include <string.h>
+
+ #include "glext.h"
+ #include "sstream.h"
diff --git a/crack-attack-1.1.14-glutInit.patch b/crack-attack-1.1.14-glutInit.patch
new file mode 100644
index 000000000000..959f29843b3f
--- /dev/null
+++ b/crack-attack-1.1.14-glutInit.patch
@@ -0,0 +1,11 @@
+diff -ur crack-attack-1.1.14.vanilla/src/Attack.cxx crack-attack-1.1.14/src/Attack.cxx
+--- crack-attack-1.1.14.vanilla/src/Attack.cxx 2005-05-13 21:00:02.000000000 +0200
++++ crack-attack-1.1.14/src/Attack.cxx 2006-05-04 09:56:04.000000000 +0200
+@@ -83,6 +83,7 @@
+ int height = -1, width = -1;
+
+ player_name[0] = '\0';
++ glutInit(&argc, argv);
+ parseCommandLine(argc, argv, mode, port, host_name, player_name, height, width);
+ run_crack_attack(mode, port, host_name, player_name, height, width);
+