summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-08-03 08:01:57 +0000
committerGeorge Rawlinson2021-08-03 08:01:57 +0000
commit642375adeee0d7b4dbc1f96bf04ce7757dd804d7 (patch)
tree27a0357eb7bae085d58361a850fd378c1f90e3cb
downloadaur-642375adeee0d7b4dbc1f96bf04ce7757dd804d7.tar.gz
addpkg: libmobi 0.6-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85d63c1fdbee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libmobi
+ pkgdesc = Library for handling Kindle formats of ebook documents
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://github.com/bfabiszewski/libmobi
+ arch = x86_64
+ license = LGPL3
+ depends = libxml2
+ depends = zlib
+ source = https://github.com/bfabiszewski/libmobi/releases/download/v0.6/libmobi-0.6.tar.gz
+ b2sums = 7c25d5bb4414e5f90b57be1b7b0668c5fc535f670904862779331896933c699469049fcc3a0ccc0ae6c6cbe8819b87f461cbaf65adb20704b6e3a1f6114f7c55
+
+pkgname = libmobi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..851fc73429b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+
+pkgname=libmobi
+pkgver=0.6
+pkgrel=1
+pkgdesc="Library for handling Kindle formats of ebook documents"
+arch=('x86_64')
+url="https://github.com/bfabiszewski/libmobi"
+license=('LGPL3')
+depends=('libxml2' 'zlib')
+source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+b2sums=('7c25d5bb4414e5f90b57be1b7b0668c5fc535f670904862779331896933c699469049fcc3a0ccc0ae6c6cbe8819b87f461cbaf65adb20704b6e3a1f6114f7c55')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make test
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}