summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2023-12-17 18:39:48 +0800
committerq234rty2023-12-17 18:39:48 +0800
commit64345433ed85d0c2542d6e0a6d368f2d0ffe013b (patch)
treebd2632ea0ff0202c4ceb740fad01bb9afa6bfe05
parent8cb896d1484922a88a35761c8c687e6b73c3de8f (diff)
downloadaur-64345433ed85d0c2542d6e0a6d368f2d0ffe013b.tar.gz
Update to 8.4.0 & quiche 0.18.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52ef5c115249..e72462b46103 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = curl-http3
pkgdesc = An URL retrieval utility and library - compiled with HTTP/3 support - binary is called curl3
- pkgver = 8.4.0
+ pkgver = 8.5.0
pkgrel = 1
url = https://curl.haxx.se
arch = x86_64
@@ -25,12 +25,12 @@ pkgbase = curl-http3
depends = zlib
depends = zstd
depends = libzstd.so
- source = https://curl.haxx.se/download/curl-8.4.0.tar.gz
- source = https://curl.haxx.se/download/curl-8.4.0.tar.gz.asc
- source = git+https://github.com/cloudflare/quiche.git#tag=0.18.0
+ source = https://curl.haxx.se/download/curl-8.5.0.tar.gz
+ source = https://curl.haxx.se/download/curl-8.5.0.tar.gz.asc
+ source = git+https://github.com/cloudflare/quiche.git#tag=0.20.0
source = git+https://github.com/google/boringssl.git
validpgpkeys = 27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2
- sha512sums = 375d241effccde852cfba32aa61be406f6c6e8ef2773b48d57bfa1ff99fdf414dc08bdb6b3a65930e53b28e31246a4bc396c81054ae9c560a3bf58cca0ae78b0
+ sha512sums = 1ff70e8fd5f233b373dea2a031d46698c03ed35f384c2eacbe9368f9daed65e91d7f45ade350c3ac3dd3d662c913b17cdc8702a0c23879b0c78fbd396fd0b926
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c6b885487710..76e87a54347d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hendrik 'T4cC0re' Meyer <aur@t4cc0.re>
pkgname=curl-http3
-pkgver=8.4.0
+pkgver=8.5.0
pkgrel=1
pkgdesc="An URL retrieval utility and library - compiled with HTTP/3 support - binary is called curl3"
arch=('x86_64')
@@ -10,7 +10,7 @@ depends=('ca-certificates' 'brotli' 'libbrotlidec.so' 'libgssapi_krb5.so'
'krb5' 'libidn2' 'libidn2.so' 'libnghttp2' 'libpsl' 'libpsl.so'
'libssh2' 'libssh2.so' 'openssl' 'zlib' 'zstd' 'libzstd.so')
makedepends=('rust' 'git' 'go' 'cmake')
-_quiche_ref=0.18.0
+_quiche_ref=0.20.0
source=("https://curl.haxx.se/download/curl-$pkgver.tar.gz"{,.asc}
"git+https://github.com/cloudflare/quiche.git#tag=${_quiche_ref}"
"git+https://github.com/google/boringssl.git")
@@ -18,6 +18,7 @@ validpgpkeys=('27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2') # Daniel Stenberg
prepare() {
cd quiche
+ git revert -n a1b212761c6cc0b77b9121cdc313e507daf6deb3
git submodule init
git config submodule.boringssl.url "${srcdir}"/boringssl
git -c protocol.file.allow=always submodule update quiche/deps/boringssl
@@ -60,7 +61,7 @@ package() {
cd "curl-${pkgver}"
make DESTDIR="$pkgdir" install
- LD_LIBRARY_PATH=$PWD/../quiche/target/release make DESTDIR="$pkgdir" install -C scripts
+ LD_LIBRARY_PATH=$PWD/../quiche/target/release${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} make DESTDIR="$pkgdir" install -C scripts
cd ..
@@ -79,7 +80,7 @@ package() {
install -Dm644 quiche/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING-quiche"
install -Dm644 quiche/quiche/deps/boringssl/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-boringssl"
}
-sha512sums=('375d241effccde852cfba32aa61be406f6c6e8ef2773b48d57bfa1ff99fdf414dc08bdb6b3a65930e53b28e31246a4bc396c81054ae9c560a3bf58cca0ae78b0'
+sha512sums=('1ff70e8fd5f233b373dea2a031d46698c03ed35f384c2eacbe9368f9daed65e91d7f45ade350c3ac3dd3d662c913b17cdc8702a0c23879b0c78fbd396fd0b926'
'SKIP'
'SKIP'
'SKIP')