summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMitch Bigelow2020-04-21 23:56:06 -0400
committerMitch Bigelow2020-04-21 23:56:06 -0400
commit64436774e6fdae90a5d2a0ee1deeace7c0ce5d67 (patch)
tree10980672a4a0138ba2f8c107ffbf3a3f55585f87
parent98b61301fd26af6d9134c70bb5fcb6c4b7c6585e (diff)
downloadaur-64436774e6fdae90a5d2a0ee1deeace7c0ce5d67.tar.gz
new upstream! support for gtk3 and qt5
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD47
2 files changed, 28 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8f52a3dc2e7..bb3b17c04087 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = xautoclick
pkgdesc = Automates repetitive mouse clicking to reduce RSI.
- pkgver = 0.31
- pkgrel = 5
- url = http://xautoclick.sourceforge.net
+ pkgver = 0.33
+ pkgrel = 1
+ url = https://github.com/qarkai/xautoclick
arch = i686
arch = x86_64
- license = GPL
- depends = libxtst
- optdepends = gtk: for gtk based gui
- optdepends = gtk2: for gtk2 based gui
- optdepends = qt3: for qt3 based gui
- optdepends = qt4: for qt4 based gui
- optdepends = fltk: for fltk based gui
- source = http://downloads.sourceforge.net/project/xautoclick/xautoclick/xautoclick-0.31/xautoclick-0.31.tar.gz
- md5sums = 87f6446c084e19f1f7c23db5256ff224
+ license = GPL2
+ makedepends = cmake
+ depends = gtk3
+ optdepends = qt5-core: (compile time) for qt5 based gui
+ optdepends = fltk: (compile time) for fltk based gui
+ source = https://github.com/qarkai/xautoclick/archive/v0.33.tar.gz
+ sha256sums = ce0fcd72758fa9b40a867b2e46914512c42f986b37d596c56ba86516bab3ea02
pkgname = xautoclick
diff --git a/PKGBUILD b/PKGBUILD
index 0257bc081786..1d807d46bbec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,29 @@
# Maintainer: Mitch Bigelow <ipha00@gmail.com>
-# Contributor: Ray Griffin <rorgoroth@gmail.com>
-# Contributor: Mariusz Kujawski <marinespl@gmail.com>
-# Contributor: Wes Brewer <brewerw@gmail.com>
pkgname=xautoclick
-pkgver=0.31
-pkgrel=5
+pkgver=0.33
+pkgrel=1
pkgdesc="Automates repetitive mouse clicking to reduce RSI."
arch=('i686' 'x86_64')
-url="http://xautoclick.sourceforge.net"
-license=('GPL')
-depends=('libxtst')
-optdepends=('gtk: for gtk based gui'
- 'gtk2: for gtk2 based gui'
- 'qt3: for qt3 based gui'
- 'qt4: for qt4 based gui'
- 'fltk: for fltk based gui')
-source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('87f6446c084e19f1f7c23db5256ff224')
+url="https://github.com/qarkai/xautoclick"
+license=('GPL2')
+depends=('gtk3')
+makedepends=('cmake')
+optdepends=('qt5-core: (compile time) for qt5 based gui'
+ 'fltk: (compile time) for fltk based gui')
+source=(https://github.com/qarkai/xautoclick/archive/v${pkgver}.tar.gz)
+sha256sums=('ce0fcd72758fa9b40a867b2e46914512c42f986b37d596c56ba86516bab3ea02')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- ./configure \
- --prefix=${pkgdir}/usr
-
- sed -i 's/LDFLAGS=/LDFLAGS=-lstdc++ /' config.mak
-
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ [ -d build ] && rm -rf build
+ mkdir -p build && cd build
+ cmake ../ \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- make DESTDIR=${pkgdir} install
-
- install -d ${pkgdir}/usr/share
- mv ${pkgdir}/usr/man ${pkgdir}/usr/share
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ make DESTDIR=${pkgdir} install
}