summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDikiy2017-02-16 02:58:26 +0100
committerDikiy2017-02-16 02:58:26 +0100
commit646be61bb97346c68368c330d9b2f7a36ab8e1df (patch)
tree19ac954c92d23f3224dfdeeb7456a924e699f30e
downloadaur-646be61bb97346c68368c330d9b2f7a36ab8e1df.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
-rw-r--r--unanchor.patch20
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eefeb46c8e92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = emkatic
+ pkgdesc = Emulator of modern Russian RPN programmable calculators MK-152, MK-161 series (the successor of MK-52,MK-61)
+ pkgver = 0.29
+ pkgrel = 1
+ url = https://sourceforge.net/projects/emkatic/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = lazarus
+ makedepends = fpc
+ source = https://sourceforge.net/projects/emkatic/files/eMKatic%20Source/emkatic-0.29-src.tar.gz
+ md5sums = b6d1c3926ac4847f56e85a327e501519
+
+pkgname = emkatic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35a7bfbbebf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Dikiy <dikiy_evrej[at]web[dot]de>
+pkgname=emkatic
+pkgver=0.29
+pkgrel=1
+pkgdesc="Emulator of modern Russian RPN programmable calculators MK-152, MK-161 series (the successor of MK-52,MK-61)"
+url="https://sourceforge.net/projects/emkatic/"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=()
+makedepends=('lazarus' 'fpc')
+conflicts=()
+replaces=()
+backup=()
+#install=''
+source=(https://sourceforge.net/projects/emkatic/files/eMKatic%20Source/$pkgname-$pkgver-src.tar.gz)
+md5sums=('b6d1c3926ac4847f56e85a327e501519')
+
+build() {
+
+ cd "${srcdir}/$pkgname-$pkgver-src"
+ patch -p1 < ../../unanchor.patch
+
+ lazbuild --bm=Release emkatic.lpi
+}
+
+package() {
+ cd "${srcdir}/$pkgname-$pkgver-src"
+ mkdir -p "$pkgdir/usr/share/doc/emkatic"
+ install -Dm644 *.txt "$pkgdir/usr/share/doc/emkatic"
+
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/128x128/apps/"
+ install -Dm644 "emkatic.ico" "$pkgdir/usr/share/icons/hicolor/128x128/apps/"
+
+ mkdir -p "$pkgdir/usr/bin"
+ install -Dm755 "emkatic.linux-i386" "$pkgdir/usr/bin/"
+
+ cat > emkatic.sh <<EOF
+#!/bin/bash
+
+emkatic.linux-i386 -p
+EOF
+
+ install -Dm755 "emkatic.sh" "$pkgdir/usr/bin/emkatic"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/unanchor.patch b/unanchor.patch
new file mode 100644
index 000000000000..d69940821f97
--- /dev/null
+++ b/unanchor.patch
@@ -0,0 +1,20 @@
+diff -u emkatic-0.29-src-orig/main.lfm emkatic-0.29-src/main.lfm
+--- emkatic-0.29-src-orig/main.lfm 2017-01-29 14:47:11.000000000 +0100
++++ emkatic-0.29-src/main.lfm 2017-02-16 02:11:02.733631645 +0100
+@@ -5,7 +5,6 @@
+ Width = 341
+ AllowDropFiles = True
+ BorderIcons = [biSystemMenu, biMinimize]
+- BorderStyle = bsSingle
+ Caption = 'MainForm'
+ ClientHeight = 381
+ ClientWidth = 341
+@@ -21,7 +20,7 @@
+ OnPaint = FormPaint
+ OnShow = FormShow
+ PopupMenu = ServiceMenu
+- Position = poScreenCenter
++ Position = poDefault
+ LCLVersion = '1.6.2.0'
+ object AboutPanel: TPanel
+ Left = 120