summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2020-11-20 16:30:56 +0100
committerAleksandar Trifunovic2020-11-20 16:30:56 +0100
commit64b06922984770d961fc308edac2cb4a18b06c36 (patch)
tree6f94b8c359dae1c9b37693767a6a3deff75ecd54
parent76fd7dc620927f57083fbec132bb945db43ab430 (diff)
downloadaur-64b06922984770d961fc308edac2cb4a18b06c36.tar.gz
v3.1.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6437b23f22c6..653e8b7cba4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lightgbm
pkgdesc = Distributed gradient boosting framework based on decision tree algorithms.
- pkgver = 3.0.0
+ pkgver = 3.1.0
pkgrel = 1
url = https://github.com/Microsoft/LightGBM
arch = x86_64
@@ -12,13 +12,12 @@ pkgbase = lightgbm
depends = boost-libs
depends = ocl-icd
depends = openmpi
- source = https://github.com/Microsoft/LightGBM/archive/v3.0.0.tar.gz
- sha256sums = 940563ece81d94eb843c2d1dc702da5af7c2a67fb1ccf31d64b39e00262d35b5
+ source = https://github.com/Microsoft/LightGBM/archive/v3.1.0.tar.gz
+ sha256sums = 5575c5abc4630b1ecb5990363bdaf25118efbd48416dda930f390689cfc58040
pkgname = lightgbm
pkgname = python-lightgbm
- arch = any
depends = lightgbm
depends = python-numpy
depends = python-scipy
diff --git a/PKGBUILD b/PKGBUILD
index f62777319f7e..bad562962ee7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=LightGBM
pkgbase=lightgbm
pkgname=("${pkgbase}" "python-${pkgbase}")
-pkgver=3.0.0
+pkgver=3.1.0
pkgrel=1
pkgdesc="Distributed gradient boosting framework based on decision tree algorithms."
arch=('x86_64')
@@ -12,7 +12,7 @@ license=('MIT')
depends=('boost-libs' 'ocl-icd' 'openmpi')
makedepends=('boost' 'cmake' 'opencl-headers' 'python-setuptools')
source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('940563ece81d94eb843c2d1dc702da5af7c2a67fb1ccf31d64b39e00262d35b5')
+sha256sums=('5575c5abc4630b1ecb5990363bdaf25118efbd48416dda930f390689cfc58040')
build() {
cd "${_pkgname}-${pkgver}"
@@ -24,7 +24,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DUSE_OPENMP=ON \
-DUSE_GPU=ON \
- -DUSE_MPI=ON \
+ -DUSE_MPI=ON
cmake --build build
}
@@ -37,7 +37,6 @@ package_lightgbm() {
package_python-lightgbm() {
depends=('lightgbm' 'python-numpy' 'python-scipy' 'python-scikit-learn')
- arch=('any')
cd "${_pkgname}-${pkgver}/python-package"
# use library from /usr/lib instead of making a copy