summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2010-08-18 20:04:42 -0400
committerSlashbunny2010-08-18 20:04:42 -0400
commit64b0abc3b825200af766bcfa03fd6196989667d5 (patch)
treeaca721548a4fa2b118cb7568240ca3e3763249d4
parent9e4d8094ce3db7edc034f72decc8bdcdd86d5191 (diff)
downloadaur-64b0abc3b825200af766bcfa03fd6196989667d5.tar.gz
Added 64bit support (thanks babets)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--wolf.install13
3 files changed, 28 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37b868c67871..3bdc177d8422 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = wolf
pkgdesc = Return to Castle Wolfenstein is a single and multiplayer first person shooter. You need the retail game files to play.
pkgver = 1.41b
- pkgrel = 3
+ pkgrel = 4
url = http://zerowing.idsoftware.com/linux/wolf/
install = wolf.install
arch = i686
license = custom
- depends = libgl
- depends = libxext
+ optdepends = xdg-utils: for opening urls
+ optdepends = et-sdl-sound: for sdl/alsa support
source = wolfsp.desktop
source = wolfmp.desktop
source = wolf.launcher
diff --git a/PKGBUILD b/PKGBUILD
index 57fb34078ad1..9d62a690f6a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,15 @@
pkgname=wolf
pkgver=1.41b
-pkgrel=3
+pkgrel=4
pkgdesc="Return to Castle Wolfenstein is a single and multiplayer first person shooter. You need the retail game files to play."
arch=('i686')
url="http://zerowing.idsoftware.com/linux/wolf/"
license=('custom')
-depends=('libgl' 'libxext')
-makedepends=()
+[ "${CARCH}" = "i686" ] && depends=('libgl' 'libxext')
+[ "${CARCH}" = "x86_64" ] && depends=('lib32-libgl' 'lib32-libxext')
+optdepends=('xdg-utils: for opening urls'
+ 'et-sdl-sound: for sdl/alsa support')
install='wolf.install'
source=('wolfsp.desktop' 'wolfmp.desktop' \
'wolf.launcher' 'wolfsp.launcher' 'wolfmp.launcher' 'wolfded.launcher' \
@@ -91,5 +93,12 @@ build() {
# Install Icon File (Multi Player)
install -D -m 644 $pkgdir/opt/wolf/WolfMP.xpm \
$pkgdir/usr/share/pixmaps/WolfMP.xpm
-}
+ # Remove Licenses from Data Directory
+ rm $pkgdir/opt/wolf/Docs/License.txt
+ rm $pkgdir/opt/wolf/pb/PB_EULA.txt
+
+ # Use a more modern way for opening urls
+ rm $pkgdir/opt/wolf/openurl.sh
+ ln -s /usr/bin/xdg-open $pkgdir/opt/wolf/openurl.sh
+}
diff --git a/wolf.install b/wolf.install
index 9dc18e2ef834..050936e9a9b1 100644
--- a/wolf.install
+++ b/wolf.install
@@ -2,11 +2,17 @@
post_install() {
echo ">>> Copy the following files off a Windows installation or CD-ROM to the"
echo ">>> /opt/wolf/main/ directory in order to play:"
- echo ">>>"
echo ">>> pak0.pk3"
echo ">>> sp_pak1.pk3"
echo ">>> mp_pak0.pk3"
echo ">>>"
+ echo ">>> Then run the following commands: "
+ echo ">>> chown root:root /opt/wolf/main/{pak0.pk3,sp_pak1.pk3,mp_pak0.pk3}"
+ echo ">>> chmod 0444 /opt/wolf/main/{pak0.pk3,sp_pak1.pk3,mp_pak0.pk3}"
+ echo ">>>"
+ echo ">>> For more information about these files read "
+ echo ">>> /opt/wolf/INSTALL (line 15)"
+ echo ">>>"
}
post_upgrade() {
@@ -17,6 +23,11 @@ pre_remove() {
/bin/true
}
+post_remove() {
+ echo ">>> To complete the uninstallation remove the RtCW data directory:"
+ echo ">>> rm -r /opt/wolf/"
+ echo ">>>"
+}
op=$1
shift