summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Wilms2020-11-08 12:55:22 +0100
committerKevin Wilms2020-11-08 12:55:22 +0100
commit64b59df0361492100b3ade510215608167adb21a (patch)
tree8795b38753eb7a72b572018f9b0a12d3d4314899
parent2c89cfb251d5590694ad080457a4ea27a0a13187 (diff)
downloadaur-64b59df0361492100b3ade510215608167adb21a.tar.gz
Fixed some bugs while building and fixed .desktop file
-rw-r--r--PKGBUILD9
-rw-r--r--facebook-desktop-app.desktop4
2 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 521169a389f4..2ba6d832b5c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: NobodyDBG <niemandausduisburg@gmx.net>
pkgname=facebook-desktop-app
+_pkgname=Facebook-Desktop-App
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Facebook Desktop built with nativefier (electron)"
arch=("armv7l" "i686" "x86_64")
url="https://www.facebook.com"
@@ -15,7 +16,7 @@ source=(
"${pkgname}.desktop")
sha256sums=(
"dad893597cee2d49406c054380f9c338d1838db41083896ded6ccc6f26d8ef6a"
- "d8e85271691a7f23fcfa7cb04b6435da4c7b0707644fddef9339ae15466e51a7"
+ "cbaf2e041b567660d62fcc9ef92b4ece2f2eba0a392c77acefd845a79a1910d8"
)
build() {
@@ -35,8 +36,8 @@ build() {
package() {
install -dm755 "${pkgdir}/"{opt,usr/{bin,share/{applications,licenses/${pkgname}}}}
- cp -rL "${srcdir}/${pkgname}-linux-x64"* "${pkgdir}/opt/${pkgname}"
- ln -s "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ cp -rL "${srcdir}/${_pkgname}-linux-x64"* "${pkgdir}/opt/${pkgname}"
+ ln -s "/opt/${pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -Dm644 "${pkgdir}/opt/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
for _size in "192x192" "128x128" "96x96" "64x64" "48x48" "32x32" "24x24" "22x22" "20x20" "16x16" "8x8"
diff --git a/facebook-desktop-app.desktop b/facebook-desktop-app.desktop
index b8619cefff46..cd30769d44ca 100644
--- a/facebook-desktop-app.desktop
+++ b/facebook-desktop-app.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
Name=Facebook Desktop App
Comment="Facebook Desktop built with nativefier (electron)"
-Exec=Facebook-Desktop-App
-Icon=Facebook-Desktop-App
+Exec=facebook-desktop-app
+Icon=facebook-desktop-app
Encoding=UTF-8
Terminal=false
StartupNotify=true