summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoron Behar2018-08-11 20:07:11 +0300
committerDoron Behar2018-08-11 20:07:11 +0300
commit64d00a0c8c47cb796f6a6450fd41df09b86a38ce (patch)
treee468766602bff96c78ebdb27defe98d06d6c0f1a
downloadaur-64d00a0c8c47cb796f6a6450fd41df09b86a38ce.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00e94fd662f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-bidi
+ pkgdesc = BIDI algorithm related functions
+ pkgver = 0.4.0
+ pkgrel = 3
+ url = https://github.com/MeirKriheli/python-bidi
+ arch = any
+ license = LGPL
+ makedepends = python-setuptools
+ depends = python-wheel
+ options = !emptydirs
+ source = https://github.com/MeirKriheli/python-bidi/archive/v0.4.0.tar.gz
+ md5sums = 74ec522efab0328e3471e58ab8007131
+
+pkgname = python-bidi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f0a2c1f8fcb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Doron Behar <doron.behar@gmail.com>
+
+pkgname=python-bidi
+_pkgname=bidi
+pkgver=0.4.0
+pkgrel=3
+pkgdesc="BIDI algorithm related functions"
+arch=('any')
+makedepends=('python-setuptools')
+depends=('python-wheel')
+url="https://github.com/MeirKriheli/python-bidi"
+license=('LGPL')
+options=(!emptydirs)
+source=(https://github.com/MeirKriheli/python-bidi/archive/v${pkgver}.tar.gz)
+md5sums=('74ec522efab0328e3471e58ab8007131')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg 'Building...'
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+# vim:set ts=2 sw=2 et: