summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Javier Araya Navarro2020-07-02 11:24:43 -0600
committerJorge Javier Araya Navarro2020-07-02 11:27:11 -0600
commit64fe549b77cf14b945cd9227f334d534ce64d0d4 (patch)
tree0300f11718199c32c52b0fdef7bfef75ffc71e22
parentef001b77d1dca9e8d46b43e3f61847f3c6212447 (diff)
downloadaur-64fe549b77cf14b945cd9227f334d534ce64d0d4.tar.gz
chg: Add additional Makefile target
-rw-r--r--.SRCINFO2
-rw-r--r--Makefile9
-rw-r--r--PKGBUILD2
3 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4f55615cbdc..e928a5fc6494 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = godot
pkgdesc = An advanced, feature packed, multi-platform 2D and 3D game engine
pkgver = 3.2.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.godotengine.org
arch = i686
arch = x86_64
diff --git a/Makefile b/Makefile
index f224580dd9d7..3a8706e0c5d2 100644
--- a/Makefile
+++ b/Makefile
@@ -5,3 +5,12 @@ get-checksum:
.PHONY: update
update: get-checksum
makepkg --printsrcinfo > .SRCINFO
+
+# you may want to do a setup previous to use this target
+# follow https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_clean_chroot#Classic_way
+.PHONY: build
+build:
+ @echo "updating ${CHROOT}/root chroot environment..."
+ @arch-nspawn $CHROOT/root pacman -Syu
+ @echo "building package in isolation"
+ makechrootpkg -c -r $CHROOT
diff --git a/PKGBUILD b/PKGBUILD
index 5fbf16ee96fc..e8d53a2ea2aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=godot
pkgver=3.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="An advanced, feature packed, multi-platform 2D and 3D game engine"
url="http://www.godotengine.org"
license=('MIT')