summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio2018-01-04 11:17:48 +0100
committerFabio2018-01-04 11:17:48 +0100
commit654f1919e6dde9c369350b90a932cfabccd006d5 (patch)
tree8be52271aa8d9249c5984c2ed7c7ba75a5524709
parent818ee2bbd8b201f238eb72eb7a6ed0aa153927c3 (diff)
downloadaur-654f1919e6dde9c369350b90a932cfabccd006d5.tar.gz
update to 0.3.3.3 and use the new upstream repository
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc839c084a41..8a8696e2bef9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = pinball-unofficial
- pkgdesc = The Emilia Pinball Project Unofficial version 0.3.2 with 2 new tables
- pkgver = 0.3.3
+ pkgdesc = The Emilia Pinball Project unofficial version with 2 new tables
+ pkgver = 0.3.3.3
pkgrel = 1
- url = https://github.com/sergiomb2/pinball.old
+ url = https://github.com/sergiomb2/pinball
arch = i686
arch = x86_64
license = GPL2
- depends = sh
depends = sdl_mixer
depends = sdl_image
depends = mesa
@@ -15,8 +14,8 @@ pkgbase = pinball-unofficial
conflicts = pinball
options = !makeflags
options = libtool
- source = https://github.com/sergiomb2/pinball.old/archive/0.3.3.tar.gz
- sha512sums = 7bdadf505774b694da16ad9fb34e76ac32c888cf482068b19caa7c616fe456bf705366d7737d24f346ab064a4ff6e9fc4b98fe14be9699479ca3ff8a0d127cde
+ source = https://github.com/sergiomb2/pinball/archive/0.3.3.3.tar.gz
+ sha512sums = 697ab9a66bb559c54cb43f926e1aadb36fe74cdccf69bb5e248aeeecdf48fc8ccee67655ef44fb43f5c1819946faf68e6754012b782a2a189394d0b2275a7545
pkgname = pinball-unofficial
diff --git a/PKGBUILD b/PKGBUILD
index 7d497a332a23..0dedba21eb05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
# Maintainer: Fabio Rämi <fabio at dynamix-tontechnik dot ch>
pkgname=pinball-unofficial
_realname=pinball
-pkgver=0.3.3
+pkgver=0.3.3.3
pkgrel=1
-pkgdesc="The Emilia Pinball Project Unofficial version 0.3.2 with 2 new tables"
+pkgdesc="The Emilia Pinball Project unofficial version with 2 new tables"
arch=('i686' 'x86_64')
-url="https://github.com/sergiomb2/pinball.old"
+url="https://github.com/sergiomb2/pinball"
license=('GPL2')
-depends=('sh' 'sdl_mixer' 'sdl_image' 'mesa' 'gcc-libs')
+depends=('sdl_mixer' 'sdl_image' 'mesa' 'gcc-libs')
provides=('pinball=0.3.1')
conflicts=('pinball')
options=('!makeflags' 'libtool')
-source=("https://github.com/sergiomb2/${_realname}.old/archive/${pkgver}.tar.gz")
-sha512sums=('7bdadf505774b694da16ad9fb34e76ac32c888cf482068b19caa7c616fe456bf705366d7737d24f346ab064a4ff6e9fc4b98fe14be9699479ca3ff8a0d127cde')
+source=("https://github.com/sergiomb2/${_realname}/archive/${pkgver}.tar.gz")
+sha512sums=('697ab9a66bb559c54cb43f926e1aadb36fe74cdccf69bb5e248aeeecdf48fc8ccee67655ef44fb43f5c1819946faf68e6754012b782a2a189394d0b2275a7545')
build() {
- cd "${srcdir}/${_realname}.old-${pkgver}"
+ cd "${srcdir}/${_realname}-${pkgver}"
autoreconf -i
+ ./bootstrap
./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/${_realname}.old-${pkgver}"
+ cd "${srcdir}/${_realname}-${pkgver}"
make DESTDIR="${pkgdir}" install
+ make clean
install -d ${pkgdir}/usr/share/applications
install -m644 -t ${pkgdir}/usr/share/applications/ ${_realname}.desktop
}