summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2016-01-22 03:23:56 +0000
committerEmmanuel Gil Peyrot2016-01-22 03:23:56 +0000
commit655a8f88dbdd9c0352ca0e6335f9a8d3065be59c (patch)
tree35637d7946cc3e628fd36338d3938ab5690b9273
parentd107c1cbf641c93cff2e8ed3112ffa72d08e9a1b (diff)
downloadaur-655a8f88dbdd9c0352ca0e6335f9a8d3065be59c.tar.gz
Remove now-useless build options, Qt5 is now the default version.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec80d62d6dab..13060c53ebf9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,7 @@
+# Generated by mksrcinfo v8
+# Fri Jan 22 03:22:25 UTC 2016
pkgbase = swift-git
- pkgver = 3.0beta2.r87.gd5f0735
+ pkgver = 3.0beta2.r116.gf377207
pkgrel = 1
url = http://swift.im/
arch = i686
@@ -17,7 +19,7 @@ pkgbase = swift-git
pkgname = swift-im-git
pkgdesc = XMPP client written in C++ with Qt and Swiften
- depends = swiften-git=3.0beta2.r87.gd5f0735
+ depends = swiften-git=3.0beta2.r116.gf377207
depends = qt5-base
depends = qt5-multimedia
depends = qt5-webkit
diff --git a/PKGBUILD b/PKGBUILD
index 59d1daafed55..ac53e3e248ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase='swift-git'
pkgname=('swift-im-git' 'swiften-git')
-pkgver=3.0beta2.r87.gd5f0735
+pkgver=3.0beta2.r116.gf377207
pkgrel=1
arch=('i686' 'x86_64')
url="http://swift.im/"
@@ -17,12 +17,12 @@ pkgver() {
}
# Those options need to be consistent between each scons invocation.
-_scons_options='qt5=1 max_jobs=1 optimize=1 debug=0 swiften_dll=1 cxxflags="-DBOOST_SIGNALS_NO_DEPRECATION_WARNING=1"'
+_scons_options='max_jobs=1 optimize=1 debug=0 swiften_dll=1'
_directory='swift'
build() {
cd "$srcdir/$_directory"
- QTDIR=/usr ./scons $_scons_options Swift Swiften
+ ./scons $_scons_options Swift Swiften
}
package_swift-im-git() {
@@ -33,7 +33,7 @@ package_swift-im-git() {
conflicts=('swift-im')
cd "$srcdir/$_directory"
- QTDIR=/usr ./scons $_scons_options SWIFT_INSTALLDIR="$pkgdir/usr/" "$pkgdir/usr/"
+ ./scons $_scons_options SWIFT_INSTALLDIR="$pkgdir/usr/" "$pkgdir/usr/"
}
package_swiften-git() {
@@ -43,5 +43,5 @@ package_swiften-git() {
conflicts=('swiften')
cd "$srcdir/$_directory"
- QTDIR=/usr ./scons $_scons_options SWIFTEN_INSTALLDIR="$pkgdir/usr/" "$pkgdir/usr/"
+ ./scons $_scons_options SWIFTEN_INSTALLDIR="$pkgdir/usr/" "$pkgdir/usr/"
}