summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Oelmueller2014-08-19 14:49:10 +0200
committerChris Oelmueller2014-08-19 14:49:10 +0200
commit6565815ba04d375574db3cd44c64c25ea929b04b (patch)
tree730bf0be27070c2a9c6827b7f505ad5ec586aa9b
downloadaur-6565815ba04d375574db3cd44c64c25ea929b04b.tar.gz
unknown-horizons-git: fife-svn -> fife
For the time being, fife-git HEAD is far too unstable on some systems at least.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD26
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cdfa0fed88c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = unknown-horizons-git
+ pkgdesc = Open source real-time strategy game with the comfy Anno1602 feeling.
+ pkgver = 2013.3.830.g9367178
+ pkgrel = 1
+ url = http://www.unknown-horizons.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = CCPL
+ makedepends = git
+ makedepends = intltool
+ depends = fife
+ depends = python2
+ depends = python2-yaml
+ depends = python2-pillow
+ conflicts = unknown-horizons-svn
+ conflicts = unknown-horizons
+ replaces = unknown-horizons-svn
+ replaces = unknown-horizons
+ source = git://github.com/unknown-horizons/unknown-horizons.git
+ md5sums = SKIP
+
+pkgname = unknown-horizons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1607007779bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Chris Oelmueller <chris.oelmueller@gmail.com>
+# Contributor: Thomas Kinnen <thomas.kinnen@gmail.com>
+
+pkgname=unknown-horizons-git
+pkgver=2013.3.830.g9367178
+pkgrel=1
+pkgdesc="Open source real-time strategy game with the comfy Anno1602 feeling."
+arch=("i686" "x86_64")
+url="http://www.unknown-horizons.org"
+license=('GPL' 'CCPL')
+depends=('fife' 'python2' 'python2-yaml' 'python2-pillow')
+makedepends=('git' 'intltool')
+conflicts=('unknown-horizons-svn' 'unknown-horizons')
+replaces=('unknown-horizons-svn' 'unknown-horizons')
+source=("git://github.com/unknown-horizons/unknown-horizons.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-*}"
+ git describe --tags --match "20[0-9][0-9]\.[0-9]" | sed 's/-/./g'
+}
+
+package() {
+ cd "$srcdir/${pkgname%-*}"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}