summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDave Reisner2015-07-04 13:36:47 -0400
committerDave Reisner2015-07-04 13:36:47 -0400
commit656abf3f8a62c2b1281741ac78e962def668c58c (patch)
tree9969bd4f8f2f2702dd525b364d28939eedc1d3da
downloadaur-656abf3f8a62c2b1281741ac78e962def668c58c.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD36
-rw-r--r--pkgfile.install12
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..836857dcc43f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = pkgfile-git
+ pkgdesc = a pacman .files metadata explorer
+ pkgver = 15.7.g7ace342
+ pkgrel = 1
+ url = http://github.com/falconindy/pkgfile
+ install = pkgfile.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = perl
+ depends = libarchive
+ depends = curl
+ depends = pcre
+ depends = pacman
+ provides = pkgfile
+ provides = nosr
+ conflicts = pkgfile
+ conflicts = nosr
+ replaces = nosr-git
+ source = git://github.com/falconindy/pkgfile
+ md5sums = SKIP
+
+pkgname = pkgfile-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ba19417d753
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Dave Reisner <d@falconindy.com>
+
+pkgname=pkgfile-git
+pkgver=15.7.g7ace342
+pkgrel=1
+pkgdesc="a pacman .files metadata explorer"
+arch=('i686' 'x86_64')
+url="http://github.com/falconindy/pkgfile"
+license=('MIT')
+depends=('libarchive' 'curl' 'pcre' 'pacman')
+makedepends=('git' 'perl')
+conflicts=('pkgfile' 'nosr')
+provides=('pkgfile' 'nosr')
+replaces=('nosr-git')
+install=pkgfile.install
+source=("git://github.com/falconindy/pkgfile")
+md5sums=('SKIP')
+
+pkgver() {
+ cd pkgfile
+ git describe | sed 's/^v//;s/-/./g'
+}
+
+build() {
+ cd pkgfile
+
+ ./autogen.sh
+ ./configure
+ make
+}
+
+package() {
+ make -C pkgfile DESTDIR="$pkgdir" install
+}
+
+# vim: ft=sh syn=sh et
diff --git a/pkgfile.install b/pkgfile.install
new file mode 100644
index 000000000000..bf0c9cfa355c
--- /dev/null
+++ b/pkgfile.install
@@ -0,0 +1,12 @@
+#!/bin/bash
+
+post_install() {
+ printf "==> Run 'pkgfile --update' to initialize the database\n"
+}
+
+post_remove() {
+ # the cache dir might not be removed, notify the user
+ if [ -d var/cache/pkgfile ]; then
+ printf "==> /var/cache/pkgfile has not been removed\n"
+ fi
+}