summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntiz (Robin C.)2022-12-08 14:44:13 +0100
committerAntiz (Robin C.)2022-12-08 14:44:13 +0100
commit658ca42e2beaf4b8da12f4c7de4462b4cb036779 (patch)
tree3590b5cd5becfd32df643c3188f43894dcc2f27a
parent74f72ea6edcb02c0b3ba314e549f1c67e033eb62 (diff)
downloadaur-658ca42e2beaf4b8da12f4c7de4462b4cb036779.tar.gz
Various improvements to the PKGBUILD + Removed (post)install script
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
-rw-r--r--gnome-shell-extension.install16
4 files changed, 19 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 617b0c8eb647..60a73931d230 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = gnome-shell-extension-desktop-icons-ng
pkgdesc = A fork from the official desktop icons project, with several enhancements like Drag'n'Drop.
pkgver = 47
- pkgrel = 3
- url = https://gitlab.com/rastersoft/desktop-icons-ng/
- install = gnome-shell-extension.install
+ pkgrel = 4
+ url = https://gitlab.com/rastersoft/desktop-icons-ng
arch = x86_64
arch = i686
+ arch = aarch64
license = GPL3
- makedepends = git
makedepends = meson
makedepends = glib2
depends = gnome-shell>=3.38
- conflicts = gnome-shell-extension-desktop-icons-ng-git
- source = desktop-icons-ng-47.tar.gz::https://gitlab.com/rastersoft/desktop-icons-ng/-/archive/47/desktop-icons-ng-47.tar.gz
- sha512sums = a52131e89b54a7d7400bb0269403dbee7e5173347863721f8191a0e3b6fde7bdc3f83ee8bd71b132191e170566e237704645bb71ef3cd748a350ab60f09deb33
+ source = desktop-icons-ng-47::https://gitlab.com/rastersoft/desktop-icons-ng/-/archive/47/desktop-icons-ng-47.tar.gz
+ sha256sums = 520ae7bc4dfed49aaa17e379f21b694c51ffc789daad058c3b8617e02e4d0e24
pkgname = gnome-shell-extension-desktop-icons-ng
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index b39f3b2a183f..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!PKGBUILD
-!.gitignore
-!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index ce5c6cd4ec78..116ac986fb7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
+# Maintainer: Robin Candau <robincandau[at]protonmail[dot]com>
+# Contributor: Matrix <thysupremematrix a_t tuta d_o_t io>
# Contributor: Yamada Hayao <hayao@fascode.net>
-# Maintainer: Matrix <thysupremematrix a_t tuta d_o_t io>
-_extname='desktop-icons-ng'
-pkgname="gnome-shell-extension-desktop-icons-ng"
-pkgver="47"
-pkgrel=3
+pkgname=gnome-shell-extension-desktop-icons-ng
+_pkgname=desktop-icons-ng
+pkgver=47
+pkgrel=4
pkgdesc="A fork from the official desktop icons project, with several enhancements like Drag'n'Drop."
-arch=('x86_64' 'i686')
-url="https://gitlab.com/rastersoft/desktop-icons-ng/"
+arch=('x86_64' 'i686' 'aarch64')
+url="https://gitlab.com/rastersoft/desktop-icons-ng"
license=('GPL3')
depends=('gnome-shell>=3.38')
-makedepends=('git' 'meson' 'glib2')
-conflicts=("$pkgname-git")
-source=("$_extname-$pkgver.tar.gz::https://gitlab.com/rastersoft/$_extname/-/archive/$pkgver/$_extname-$pkgver.tar.gz")
-install="gnome-shell-extension.install"
-sha512sums=('a52131e89b54a7d7400bb0269403dbee7e5173347863721f8191a0e3b6fde7bdc3f83ee8bd71b132191e170566e237704645bb71ef3cd748a350ab60f09deb33')
+makedepends=('meson' 'glib2')
+source=("${_pkgname}-${pkgver}::${url}/-/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('520ae7bc4dfed49aaa17e379f21b694c51ffc789daad058c3b8617e02e4d0e24')
build() {
- arch-meson desktop-icons-ng-$pkgver build
- meson compile -C build
+ arch-meson "${_pkgname}-${pkgver}" build
+ meson compile -C build
}
package() {
- meson install -C build --destdir "$pkgdir"
+ meson install -C build --destdir "${pkgdir}"
}
diff --git a/gnome-shell-extension.install b/gnome-shell-extension.install
deleted file mode 100644
index f5ef8e3ebdfe..000000000000
--- a/gnome-shell-extension.install
+++ /dev/null
@@ -1,16 +0,0 @@
-post_install() {
- echo " ______________________________________________________ "
- echo " ==> / \\"
- echo " ==> / Don't forget to Restart GNOME Shell \\"
- echo " ==> \ (Alt+F2, type r) /"
- echo " \______________________________________________________/"
- echo " "
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}